Download

help with Error: "accessed none trying to read property"

Hello!
I have created a computer protected by a password for my game. I have a widget that displays the computer screen to the player where they can try and enter the password (if it’s incorrect-an error message appears). in the widget BP I created a reference to the computer class BP in order to get access to the password (text variable) that’s in the class (the widget compares the password entered by the user to the password from the BP). for some reason when I ran the game I get this error:
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_215515_1615136740479_914”,“title”:“error.png”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64
​I tried reading online and from what I understand in means the BP reference is empty. How can I fix this?
I’m using the reference twice in the widget-once to get the password and second time to activate a custom event in the computer class BP called “correct password”
this is part of the code
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_215517_1615136836875_890”,“title”:“widget.png”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64
​thank you in advance!!

Your images are broken. This error always means the same thing. Click the link on the far right of the error message and the system will take you to the offending node. The input it’s getting has not been initialized.