Download

Help with custom character moving on idle animation

So apparently, i already asked this on answerhub but still haven’t found a solution for this problem.

The problem is that my custom character is stuck on the idle when walking running but when i jump it works and the loop (In air) and the jump end.
I’ve been messing around unreal but still haven’t found the problem. Blueprint Gamemode All thirdperson. i haven’t changed anything yet, since i’m still new
The things i used is this.
Mixamo’s Auto Rigger (I’m a little lazy for now)
Hyperdimension Neptunia Models (Took out the bones so i can use mixamo’s since i tried importing with it’s default riggings which is .dae and converted it to FBX, retargeted animation to the blue guy and everything went to ****. Although i haven’t tried animating with the normal bones, i want to post this due to me really stuck for about 3 days now and from what i’m seeing, i’m the only one who got actually got the problem.)
Blender for the animations and textures.
That’s all i used.

Tutorials i used: https://www.youtube.com/watch?v=-Hrf-V_mT20 Followed everything…and for some reason my walking animation isn’t playing nor my running.
Addon Question: How can i make the ai follow me like a teammate and apparently not make him stop once he reaches me?

Pictures (I won’t take scrnshots of the idle/run transitions etc and she might be small but resize power.)
blu.PNG
1d.PNG.jpg
cbcf165dcf5d927bbf60c539e48dc44b400b3e1e.png

Oh and i can give the project since it’s only a test for the animations, after that i’m moving to blueprints.
but…i don’t know any sites that can upload a 1gb file and that send links rather than email, oh well.

Thanks in forward! Sorry if this is too long.

You didn’t set the speed in the event graph. There should be a line coming out of vector length function from the get velocity function call.

Since the speed variable is not set to the velocity of your character, the speed is always 0 and thus the blendspace is not being fed the appropriate values.

Oh gosh i was an idiot…how come i didn’t notice that…well i got it working, thanks Alpha!

Having the same issues my character is moving in the idle position…
Screenshot (1).jpg
Screenshot (2).jpg
Screenshot (3).jpg

You need to connect the set speed node with an execution wire to the previous node.