Download

Help with creating a 3d widget

hey guys i need your help to fix the widget I created for my actor.

bcz right now I’ve got couple of problems, one is that the widget needs to face the player where ever he goes while the player is overlapping with the box that I created in actor and the second one is scaling the widget to an appropriate size I tried to scale it down with draw size but it just made it look like cra*p so I wanna scale it down without losing quality and the third problem is that the widget is spawned at begin play while I just want it to show up when the player is close to the bed


Set the widget component to screen mode. This will give you pixel perfect quality:

image

Otherwise you’ll need to rotate it every frame with Tick, which would look close to / like this:

…and may look awkward, verging on really weird. Do test both, though!

the widget is spawned at begin play while I just want it to show up when the player is close to the bed

Select the widget component and set it to Hidden in Game in its panel. You already have a box trigger, so then you can:

1 Like

when i set it to screen it disappears

Can you show the widget hierarchy? That should be all for what you’ve got:

image

Remove canvas if you have it.

You will not see it in the editor but it will be visible in the game. You can’t see screen-space widgets outside of PIE.

1 Like

i dont see it in the game either

with the border thing i dont see it in game no matter what world or screen space i only see in preview

wait i made mistake i set it hidden in game and didnt turn it back on lol… sorry

1 Like

Do tell how it looks and feels and, most importantly, whether it works.

You could try it with the rotation but it can be confusing, especially when you look at something from above as it performs a gimbal flip.

when set to screen it does rotate to camera and looks fine, but there is one more problem is that the text looks out of its place cuz only half of it is visible how do i scale it down should i do it from actor or from widget? and i dont know how to do it from widget

this is how it looks right now i managed to fix the text but its still big and scaling it down from actor doesnt do anything

In the widget, Set Custom on Screen size to what you need, this is the preview size:

and should be the same as on the component:

This way what you see in the Widget Designer will be same as in the game. Don’t use any scaling. You can also adjust the Font size, of course.

1 Like

thank u so much dude i got it working exactly as I wanted. every time i come here and ask questions u are the one answering. u r life saving.

1 Like

As a bonus you get the transparency working now, too!

1 Like

uhh, one more question in the panel it says the widget is ticked every frame even if it’s hidden isn’t that gonna hurt performance? especially since I’m gonna have so many of these beds around my level? should I disable tick mode when overlap ends?

here’s what i did.

1 Like