Download

Help with Basic Stacking mod

Hey guys

Im quite new to modding but want to get into it quite badly, but I need some help.

I have been trying to create a basic stacking mod just to lift some of the base resources (wood, thatch, fiber, berries) stacking amounts to make the inventory a bit cleaner but I have run into a wall it seems.

I might be missing something because I copied the blueprints for ex. wood into my mod folder along with Primalgamedata and genericmod files. Then I edited the quantity it stacks to and saved and uploaded.

When I check the folder on the server im testing on, it has all the files except the ones I edited and obviously it doesnt work. What am I missing, should I change any references? If so, how do I make sure I change it everywhere?

It’s not overtly complicated, I’ve never tweaked with resources but I just did it with Wood to test.

Make sure you have all your necessary files in your mod folder. I’m just going to use wood as the example here.

**PrimalItemResource_Wood_*****YourModNameHere *(or another unique identifier - will save you at some point in your modding life to be sure)
Edit what you want to here, like weight and stack size. Compile it, you can save now or save everything later, compiling just solidifies changes enough that the Editor can run them, and when working in the Graphs I’ve found compiling needs to be done a lot - but you don’t really need that here.
**
TestGameMode_YourModNameHere

You’ll need to change the Game Mode Override in PrimalGameData.

**PrimalGameData_BP_*****YourModNameHere ***(it’s recommended to do this to each file you copy and modify, that way you can easily search for and know which ones are your modified ones)
Open it and go to “Primary Resources” and expand the list. Find wood on the list, and make sure that your custom PrimalItemResource is selected in the content browser, then click the little arrow next to the field in the PrimalGameData and it will replace the asset to load in-game with the one you have selected. Or you can just click the drop down, it will load all assets that can be used, then just search for wood and you should see yours there then select it. Compile. Don’t forget, you also set the in-game name of your mod and it’s description in this file.


YourModNameHere***(Level) - or you can leave it as the GenericMod if you wish.
Open the level, on the right you(may or may not) have the “World Settings” tab, if it’s not there, hit settings which should be top center-ish, then World Settings. In the new tab at the right, scroll down and replace the “PrimalGameData Override” with your new/custom one. Save.

Now, if my brain hasn’t screwed me over with typing this out, you should be able to witness the changes in-game by loading the SmallIsland map… “File > Open Level > SmallIslandSubMaps > TheSmallIsland(Level)”. Once the map has loaded, it will take a couple of minutes to load in textures, compile some shaders and what have you, select your PrimalGameData from your mod folder in the content browser, go to the World Settings panel again at the right, click the little arrow and your mod should be loaded when you hit “Play” at the top.

Once you’re playing in the editor, if you’re in the SmallIsland map, go and cut down a tree, and check the stack size on the wood you’ve collected, if it’s what you set it to, the mod is working. From there, if you want others to use it, or even if you want to use it yourself in a client, hit the Steam Upload button, select your mod from the left in the new window, enter the name of the **Level **file in your mod in the Mod Maps field(if you do not do this, the mod will **not **work in a client), then click Cook Mod.

It will take a minute or two, it may take longer, it depends on a couple of factors. The mod should cook successfully, and will tell you if so. Disregard the seven-odd thousand warnings that will show up, those basically show up because those are all the assets from the game that aren’t being included in the mod, it just likes to let you know they’re all missing. As long as there were no errors, you should be good.

From there, uploading is only possible if you populate every field for the upload section not including change notes. Pick a title that will appear in the workshop, choose an icon from somewhere, descriptions have caused issues for me and some others so I would just put whatever in(you can edit it on the workshop page on Steam later if you wish to), then choose a visibility setting. If the mod is just for yourself/friends or you’re testing in a client, choose friends(I’ve heard of problems with hidden and mods not downloading), otherwise public. From there, you’ll need to enter your steam login details. A small CMD/DOS box will popup, pay attention to this and note any errors, the DevKit will not report any errors from uploading, and the CMD box disappears a second or two after errors appear.

If it doesn’t error on you, it will go through it’s little checklist and the mod is uploaded to the workshop. Once that is done, there should be a “View Item on Steam Workshop” hyperlinked text line next to “Mod Directory” in the cook/upload screen.

Let us know how you go, hopefully what I’ve shared here will help you. If not, I’m sure others can enter their input. I’ve only just started modding myself, and I’m currently tackling diagonal walls and making them scale upon snapping… not easy, haha.

-WM

Wow thanks for the detailed rundown dude, Ill give it a go and see if it works.

You sir are a legend and a scholar

OKay I followed your post to the letter and it looks like its testing fine in the editor like you described with Wood stacking without a problem like I wanted to.

But when I download the mod to my test server, I only see 4 files in my mod directory : “.mod”, “mod.info” , “Modmeta.info” , <Modname>.umap. Is this correct, should I not be seeing the files as are in my mod folder during the editor.

The mod does not seem to work on my dedicated (windows) server, as wood stacks are completely unchanged. Did I miss something with the cooking or uploading perhaps? What would cause those files to be missing if they should be there?

In the editor, your mod folder should have the four files, PrimalItemResource_Wood_x, PrimalGameData_BP_x, TestGameMode_x and x(Level). Then, Cook Mod.

Also note that using mods on servers is different to local play, if you weren’t aware already.

If the files aren’t showing up - which yes they should be in the mod folder when downloaded, either the mod didn’t upload correctly/completely, didn’t download correctly/completely or the mod was cooked incorrectly. Make sure all the files are in the mod folder, compile and save them all, cook the mod as a Mod, not a map or conversion, then reset the mod GUID(this while force an update of the mod through steam, then upload the mod without changing anything else and it will just update the files in the workshop.

From there, to update the mod in steam, close it and start it again, it should download the updated mod… once the mod has downloaded, check again to see if the files are still not there. If they are, proceed with the method of installing mods on a server and test.

-WM

Okay resetting the mod ID seems to have worked, all the files are there as it should be now. However the stacking still doesnt work.

Ive changed the value of max quantity to 250, and it does so in the editor. Is there any other value im supposed to be editing?

Hey buddy, the way i acheived this was i made a total conversion mod. so basically create a new folder under mods and create a child of primalgamedata and the testgamemode and follow what woeful said. instead of copying the resource blueprint to your mods folder youll be editing the resource blueprints directly. if you do it through a mod the stack size will only apply to any new resource you gather. Does that make sense? Make sure you cook TC when you cook and upload tpo :stuck_out_tongue:

Oblexive, Ive read about TC’s, but the client then has to set the Total conversion everytime they want to join the server, is that correct?

I dont mind it just applying to new resources so badly, if that means not going TC then im happy. I just want a basic stack sizes mod to tweak some of the resources on a fairly new and empty server to teach myself modding

R4ziel i had worked around with stacking sizes and the only way i had got it too work out probaly was by making it as a TC since when you destroy buildings it will still give you the vanilia ressoruces which you can’t use and you have too create a force stack on all the strucutres inventories cause ex charcoal spoiled meat will only stack in 1x so there is gona be alot of remaping and modded structures for that

Okay so it looks like a TC is the only way to go for stacking which is fine. But my question still remains, will people without the TC active see the server or do they have to switch to it every time they want to play?

I can change the stack size of primary resources easily but how to change stack size or berry, raw meat and cooked meat, etc… ? :s

im not 100% positive but i would think they would have to select the TC to see it in the server list…

If they have to select the mod to view the server that is not going to work for me. There are stacking mods out there that are working without being a TC, so it is possible, I just have to play around a bit with it. There must be something im missing as it is just not working on the server.

Ill post here if I find it. Also if anyone else has any idea why its not working please let me know

It is possible but its like Nightmare said earlier, youd have to remap alot of stuff to get it to work properly and use it from the start of a new server as to not collect any vanilla versions of the resource. TC just seems to be the easiest way and you’re right. Only people with your TC active will see your server…

Hey guys, I decided to go with a Total conversion after all, which is not what I wanted to do but thats the only way to get it to work it seems.

Thanks to everyone who replied here, your help made my life so much easier.

I just wanted to confirm though, When I dont have the TC active in my client, I still see the server, I just have to relaunch the game when I try to enter the server, which is fine

Oh you can still see the server, thats cool thanks for that. :smiley:

Hey there all!
I know this is an old post … but I feel the need of necroing it, as I am pretty much stuck at trying to make stacking work as well now…

I followed the list from WoefulMacabre, started with changing wood only … tweaked it, changed the Master Item list in PrimalGameData_BP. Switched to the new PGD in the World settings, used SmallIsland map to test and it worked… saved and ended the dev kit for the day.
Now, I started it back up, feeling good, and changed all the items, values, sizes and what not the way I want my mod to be… changed all the items in the master Item list ( 357 items ) in PrimalGameData, ensured all the settings was correct … but now the mod won’t work… not even wood… I have not changed anything except the new items I have tweaked … and added the SE items into the Master Item list, as they were not present there…

Steps I’ve done:
Renamed the mod files to mymodname(level), PrimalGameData_BP_GenericMod_Mymodname, TestGameMode_GenericMod_Mymodname
Added a child of all the BPs for the items I wanted to tweak into my mod folder
Tweaked the items to my liking
Changed the items in Master Item list in PrimalGameData_BP_Generic_Mymodname to my new modded items
Changed the Primal Game Data Override to use my modded one
Changed GameMode Override to my TestGameMode file
Used SmallIsland map to test if it was working.
It was not working this time.

I don’t understand why it would work when I only changed the PrimalItemResource_Wood_Mymodname, but when I changed all the others it will not work…
Any advice?? I’m not sure what more info I should provide at this point, but if something else is needed to farther the investigation please tell me :smiley:

Should I move this to a new thread?

I noticed I could remap every item in the remap item list … but then pop the question … is also then needed to change all the items in the PrimalGameData_BP ??? or will this make an issue??
I have now remapped every item, and it works!! :smiley:

Inside you PrimalGameData_MODNAME, search for a section known as “replace” in the top search bar. it should say something along the lines of NPC replacement, SupplyCrate replacement, ect. look for the one that says Resource Replacement(you will more than likely need to click the “+” to get the option to start) and and area that says from “type”, to “type”. The From “Type” is the old wood, thatch, ect resource that stacks at a lowered amount. The To “Type” is the new resource that you made in your mod to replace it(wood, thatch, ect). Test this one at a time to make sure the resources are stacking properly and at the right amount.

Also, make sure in the World Settings tab(usually on the right of your window) make sure that the Primal Game Data setting is set to your mod’s primalgamedata. IF this is not set you will NOT be able to test your mod in the dev kit.

I’m currently not at my Main Computer but I will Crop in some Pictures to better visualize where each of these settings are located when I’m am back on that cpu.

I’ve done this mate :smiley: and that works … all wood, bullets, meat and what not is stacking when I gather it …
My issue now is that if I demolish a wall, window, or any other structure, the return items will not stack … I’m getting a bunch of 20 thatch, 10 fiber, 50 wood and so on over and over in my inventory… I need to drop them on the ground and re pick them up for them to stack …
I’m not sure why the mod can’t see the resources entering my inventory like that when demolishing a structure, but only if I chop down that tree or stone or metal node and so on …