Download

Help with assigning a custom character using the 3rd person template please...

I upgraded to 4.7.X and it seems things are setup slightly different from 4.6. I have a custom character with everything re-targeted. I can’t for the life of me figure out how to assign my custom mesh instead of the blue guy. Where do I assign that? I’m sure this is easy, but I must be overlooking something…

Thanks.

Normally it should still work like in this tutorial: https://www.youtube.com/watch?v=tyYTYF0G5Kk :slight_smile:

In the new 4.7 version:

  1. open the character bp
  2. go to the “viewport” tab
  3. select the skeletal mesh
  4. in the details panel you have to change it -> right side of the window

That worked and the re-targeted “idle” animation plays in the Viewport, but when I play the scene my character stays in the T-pose. I assigned my re-targeted animation BP along with the mesh under the details tab. Any thoughts?

Never mind, I figured it out. Thanks!

Hi Adam, I have the same problem, animations doesnt work, the character stay in the T-pose, how can i play the animations in real time? How do you figured out?

Above where you assign the mesh there is a spot where you assign the Animation Blueprint as well

I already assign the animation blueprint to my custom character anim blueprint, but it doesnt work, ii can see the animation in the viewport, but when i play my character move with the T-pose!!!

Make sure that you use the right character bp in your gamemode and double check if you have assigned the animation bp to your character bp correctly :slight_smile:

Thanks, my game mode is thirdpersongamemode, so now i have another problem, when i play and move my character theres only the idle animation that play, even i have i blendspace with idle and walk animation!!!

I actually think here may be a small bug, because I have noticed this with the latest update. If it won’t work right after updateing anim BP in the BP page, try clicking on your character pod thing in the main viewport, then update which BP blueprint its using (should be an option in the right hand area). Sometimes it doesn’t update to the same settings as in the character BP page. It should work correctly after you do this.

Yeah your right its work, thanks a lot