Download

Help with adding item to fabricator. Works in Dev Kit but not in game.

I’m trying to adjust the crafting recipe for elevator tracks. I already have a bunch of adjusted items built in the smithy that work correctly, so I did the same thing for the elevator track.

I have added an entry under ‘Additional Structure Engrams’. For Class is StorageBox_Fabricator, Class Additions is the PrimalItemStructure_ElevatorTrackBase that I adjusted. It works in the simulator within the devkit, but doesn’t show up in the fabricator in game. I can learn the engram, but it doesn’t show up. I have made new fabricators, and also tried adding in fabricators with console commands. Tried a mindwipe and re-learning the engrams. Tried deleting the mod folder and forcing it to download again.

Is this something with a new update making items in the fabricator not being linked to StorageBox_Fabricator? That’s all I can think of since it works in the Dev Kit simulator and all my smithy items work correctly.

D**o the smithy engrams**** work in-game correctly, in singleplayer ***and ***multiplayer?

-WM

Yup, works for both and the fabricator elevator track doesn’t work for either.

You have built a new fabricator after installing the mod correct? I always forgot that and was like wtf I know I did it right!
When I did this previously I had to also add the primalitemstructure as a “for class” or it would not show up in my fabricator in mp. Storagebox worked for SP but had to have structure to see it MP.

For this would you then add both classes or will one class primal work for both i am haven this same issue my first mod i used just Storagebox and it seems to work in both sp and mp. now another mod using same layout will not show up in game but all works fine in dev kit