Download

help wil animation retargeting ...

hello i’m trying to use the animation retargeting system with a model that i bought on the internet, i’m trying to retarget an animation file from the internet too.

as for as i have understood from this url https://docs.unrealengine.com/latest/INT/Engine/Animation/RetargetingDifferentSkeletons/ i just need to click on each skeleton and setup the retargeting bones.

after doing that on both skeletons i checked my model but the idle animations was just weird, also the scale of the model without animations was increased a lot.

i found the this video https://youtu.be/hw-zr2In2P8?t=1949 in a thread here on the forum, but can’t see the “Show Advanced options” check box on the skeleton tree, also i didn’t have “Recursively Set Translation retargeting Sekeleton” option in the right click menu.

any idea how to fix my retargeting problems or why i don’t see these two options in my ue4 (i’m running ue 4.15.1).

thanks in advance for all the help.

Make a play-around and export your model with 0.01 Delta scale.
I’d appreciate it if you include some screenshots :stuck_out_tongue:

hello, these are two pictures after and before retargeting

before

after (llok the weird result)

If your rig you are targeting to has got any extra finger bones than your target skeleton, its gonna mess up the targeting animations in the hands in some way. It always does., I had this issue and the only way I solved it was to keep the finger chains exactly the same as the skeleton I was targeting from which was the epic mannequin. For I had 5 chains of finger bones, Epic only had 4, the result was mangled oversized hands and it didn’t matter if I didn’t select the extra bones, it still messes up the animations. So I had to delete the extra bones from the skeleton and reimport it in again and that fixed the targeting. And I think its a similar result as well that the human animations will be deformed looking up if the skeleton you are targeting to is missing the epic twist bones. Epic uses special bones in their rigs to make the animations
more human and natural looking and without them, i don’t think you can get that same natural look.

The options you are looking for is in a different place: in he window where the bones are listed look at the right bottom corner., eye icon. You can turn on advanced view there. Then you can set the bones to skeleton from pelvis recursively, then put the pelvis to animation scaled. It might solve the problem… or not