Help using Level Sequencer or Actor Sequencer in Blueprint

I don’t think my first post was clear so editing this to try to explain better. My goal is to have a series of blueprints that contains objects and cinematics, each blueprint would then be dropped in a level or other blueprints to craate a game. I’m not sure how to accomplish this and running to problems.

Actor blueprint 1: A bus that blows up
Actor blueprint 2: A car that blows up
Actor blueprint 3: A telephone booth that blows up

The user would then take any of these blue prints and drop them in to their own level or other blueprint tg create their own game.

If I create my own level I can make the level sequencer work as expected and everything is OK, where I run in to the issue is trying to do this through a seperate blueprint.

Here are the steps I’m using

  1. Create an actor blueprint
  2. Add mesh to the blueprint
  3. Since level sequence is not available on a blueprint I thought I should use an ActorSequence
  4. From here I try to create the cinematic using the sequencer window using a transform to capture the location, rotation, and scale.
  5. As soon as I enter the first transform values the object turns red in the sequencer and says object bound to this track is missing and the object in the viewport in the BP is no longer movable

Anyone know if I’m approaching this in the right way or are their suggestions on something else I need to be doing to accomplish this? Thank you

i think u nned to remove the owner and just add the SM

Hello thanks for the suggestion, I did try that earlier but when you add the object, it adds the actorBP name above it, in the case of the example above it was called owner. Just to make sure I did not miss anything I tried it again on a new actor BP called test deleted everything then tracked using BP_Lantern but it did the same thing.

i remember i had the same problem a while ago. don’t remember how I fixed it tho let me test

okay i tested the exact same thing and i did not have any issue. idk what it could be sorry

1 Like

Awesome thank you for testing, that is helpful because at least I now know it’s something on my side and not Unreal, Testing some other versions of Unreal I was using 4.24.3 which was required by this project. Thanks again

I should have tried this before posting but thought it was a lack of knowledge on my end and something I was doing wrong. Turns out 4.24.3 this feature is not working, I tried 4.26.2 and above and it works fine. In 4.24.3 the sequencer works fine on a level but not an individual blueprint.

Thanks again @bumbumgoesnuts