HELP! The project could not be compiled. Would you like to open it in Visual Studio

Please help! I’m new to UE4, I downloaded a course from Udemy and followed the download instructions. I have visual studios 2017 with the windows 10 and 8.1 SDKs (86 & 64) and UE4 4.13.3.When I try to make a template in C++ blank I keep getting this error. It does not occur when I use a regular blueprint. I’ve tried uninstalling and downloading both programs and keep receiving the same error message.

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files (x86)/Epic Games/4.14/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject2 Development Win64 -project=“C:/Users/Dustin/Documents/Unreal Projects/MyProject2/MyProject2.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE
@progress push 5%
Parsing headers for MyProject2Editor
Running UnrealHeaderTool “C:\Users\Dustin\Documents\Unreal Projects\MyProject2\MyProject2.uproject” “C:\Users\Dustin\Documents\Unreal Projects\MyProject2\Intermediate\Build\Win64\MyProject2Editor\Development\MyProject2Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProject2Editor in 3.9915965 seconds
@progress pop
Performing 7 actions (2 in parallel)
[2/7] Resource PCLaunch.rc
[3/7] Resource ModuleVersionResource.rc.inl
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.10.25017\INCLUDE\crtdefs.h(10): fatal error C1083: Cannot open include file: ‘corecrt.h’: No such file or directory
ERROR: UBT ERROR: Failed to produce item: C:\Users\Dustin\Documents\Unreal Projects\MyProject2\Binaries\Win64\UE4Editor-MyProject2.dll
Total build time: 30.66 seconds

  • open your visual studio installer, choose Modify, choose Individual Components, choose Unreal Engine Installer under “Games and Graphics” section. Install this component should solve your problems.

Thanks, updating VS and UE4 layer helped me with that one!

Hi, I did what you you suggested, but it didn’t work, here’s what the UE saying

"The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files (x86)/UE_4.25/Engine/Binaries/DotNET/UnrealBuildTool.exe Development Win64 -Project=“C:/Users/Jourdain François/Documents/Unreal Projects/Test3/Test3.uproject” -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Creating makefile for Test3Editor (no existing makefile)
@progress push 5%
Parsing headers for Test3Editor
Running UnrealHeaderTool “C:\Users\Jourdain Fran?ois\Documents\Unreal Projects\Test3\Test3.uproject” “C:\Users\Jourdain Fran?ois\Documents\Unreal Projects\Test3\Intermediate\Build\Win64\Test3Editor\Development\Test3Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -abslog=“C:\Users\Jourdain Fran?ois\AppData\Local\UnrealBuildTool\Log_UHT.txt” -installed
Reflection code generated for Test3Editor in 5,6999004 seconds
@progress pop
Building Test3Editor…
Using Visual Studio 2019 14.27.29111 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.27.29110) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
Building 9 actions with 16 processes…
@progress ‘Compiling C++ source code…’ 0%
@progress ‘Compiling C++ source code…’ 11%
[1/9] Default.rc2
@progress ‘Compiling C++ source code…’ 22%
[2/9] SharedPCH.Engine.ShadowErrors.cpp
c1xx: fatal error C1083: Impossible d’ouvrir le fichier interm?diaire du compilateur?: ‘C:\Users\Jourdain Fran??ois\Documents\Unreal Projects\Test3\Intermediate\Build\Win64\Test3Editor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.pch’?: No such file or directory"

i have alraedy install this but this is not workig

hello im in the same situation as you. i was wondering if you fixed the problem and if you can help me

1 Like

are you still facing that issue ?