Download

Help setting up root motion!

Hey everyone,

I am making a combat system similar to the sword / knife ability in Destiny.

(jump to about a minute in to see what I am getting at)

What I want to tackle first is the basic ‘dash attack’ the character does. A simple punch where the character dashes a few feet. I have a simple animation ‘one - two punch’ animation montague set up, and I want to use root motion for the dash and have the player capsule follow the root animation, which goes forward a few feet. Root motion.

inside the animation montage, I check the root motion boxes, but that doesn’t work, all it does is disable movement input when punching, but the character still leaves the capsule and snaps back when the animation is finished.

After some research, I found this documentation:
https://docs.unrealengine.com/latest/INT/Engine/Animation/RootMotion/index.html

which I followed until I got to this part:
https://docs.unrealengine.com/latest/images/Engine/Animation/RootMotion/PressRUseHammer.jpg

ee4888f320c2b17e545346e67c0df0a4cda5e879.jpeg

…But I can’t find the ‘get anim instance’ node, or the node connected to the left there where it says ‘self - mesh’. I searched it in the add node menu, but it isn’t there.

Where can I find that? And more general, would this documentation help me achieve what I am looking for? Is root motion the best way to set this up?

Here is a video i recorded of my issue

Within my Ledge Climbing system, I can only use Root motion, if I change the movement type of character to flying. Try adding a “Set Movement Mode” to flying before starting the root motion, and change it back after finishing it.

Unfortunately, it didn’t work, he still leaves the capsule. He does float in the air when I jump and punch, however! haha.

323500002f8792b45e679d32d6165a7322a491ac.jpeg

This is my setup. Also, in the OP, I mentioned not being able to find ‘get anim instance.’ I did end up finding it, but I still can’t find that ‘self - mesh’ doohicky.

I have my Set movement Mode to flying one node before calling the root motion anim montage.

And just a small question: Are you sure that your animation has its root animated?

By root, I assume that means the highest bone on the hierarchy? Or is that incorrect?

I am currently at work, So I’ll check setting the flying mode before the root anim montague when I get home!

(Also, side note, big fan of your climbing system!)

On the picture bellow you can see that the root bone of my character is moving up. Also,you can also see that the Root is the first item at the hierarchy, on the left.

ba667d6fb281d8414b7a1a56fedebd458cc8150a.jpeg

And looking at one of your pictures (

&d=1415729623 ) you don’t have the root as the first one. I don’t know if this changes anything, but hey, it is one more thing for you to look. :wink:

Ohhh!

Blender has it set up a bit strange then, I’ll see if I can get it working. I’ll have to expirement.

That makes sense than, as he is staying in place. Lets hope this is it!

That was the issue, oh boy do I feel dumb!

Thank you!