[Help Requested] Behavior Tree not Firing.

Hey folks, I’ve been learning the AI/Behavior Tree sections of the program and in doing so I’ve done the quick start guide/tutorial found here, however when I run the program I get the following:

My service has compiled with no errors, the controller is setup to use the Blackboard as instructed and I can’t figure out why the root won’t fire down to the first selector. Has anyone else encountered this before?


You may have forget one little thing hidden somewhere in the tutorial ^^ I had this trouble and kept the time to check step by step once again all the tutorial to realise that i forgot to set some default values. (maybe the same for you, maybe another one.)

You have the last Blackboard key on the second branch set incorrectly, you currently have TargetToFollow twice in the decorators, the last one should be Target Location is Set.

That should be it I think,



Thanks Mark & Fen for your replies. Out of sheer frustration, I completely redid the tutorial figuring something like a default value might have been overlooked. I’ve made (and double checked) the adjustment you’ve suggested Mark, however my tree is still behaving the exact same way.

Here are fresh screenshots.
Behavior Tree

AI Character Setup

AI Controller

Thanks again folks :slight_smile:

[edit: grammar]

I had the same problem when I did this tutorial for the first time. I ended up putting breakpoints everywhere I could and found that I was missing a few links inside the agro service. Apparently, the missing links between the nodes made it look like only the root was firing while the tree was running (in yellow border) instead of flickering between the root and the selector node like I would expect if an error like this would occur.

Okay, I did a lot (a lot) of back tracing and troubleshooting, and I think I may have found some of the problem, which leads me to believe it might be a 4.4 bug*.
First, I forced the selector to open up to operate and observed the activity in the “Rapid Move” task, which seemed to fail out of the gate, but the tick worked fine:

I noticed that the Agrocheck wasn’t referencing the pawn by the end of the AI cycle, then went through the different casts (radius and trace by channel) and then found this:

When referencing the actor from the second trace, nothing was found, even though I could see the raycasts coming off of the Follower and hitting the pawn:

However, when I bypass the second raycast and pick directly from the first, it works fine:

To note: In the tutorial image of “Agrocheck” the line trace by channel has “Camera” selected on the dropdown, I have “visibility”. I’ve tried adding a camera to the Follower, however this does not change the options granted.

edit: Also, I had to disable the Branch at the end which compared if the two objects were the same as it was perpetually failing.


*Outside of this test in the game I’m developing, I’m having issues server side casting single line traces through authority guards specific to camera & visibility functions, while they work fine when cast by clients. I’ve had to resort to casting traces from the root capsule which seems to bypass the issues I’ve had, but makes for some challenges when picking things up in co-op. Anyway, I just believe something deeper to be amiss here, but I could be wrong]


I think it’s just some collision testing issues with the tutorial perhaps. I’ve not gone through it myself but some similar issues arose in this topic: