Help pls, capsule components bounce off one another! :(

Hey! I have two character that collide while in the air but they just keep bouncing back when they collide with each others capsule components. Does anyone know how I can make it so the characters dont bounce back off one another but stay locked with each other when they collide in the air. Thank you! :smile:

You could set InitialPushForceFactor on your CharacterMovementComponent to zero. That would probably fix it, but make it so your character doesn’t apply force to anything at all. So, I think you should make it so the Character only uses InitialPushForceFactor when on the ground, and not in the air.

Hope this helps!

1 Like

Thanks for the advice, but I tried setting InitialPushForceFactor to 0 in both character movement components and they still bounce off one another when colliding in the air.

This is when both of the characters are facing the same direction though so both facing right and one character collides from behind. If both characters are opposite directions and collide in air it works fine now :slight_smile:

I believe in the “Physics Material” you need to set “Restitution” to 0.

Sorry but where do i find the physics material?

There’s a dropdown under either “Physics” (for a Skeletal Mesh Physics object) or “Collision” for Static Mesh objects.


1 Like

Thanks but this also doesn’t work :frowning:
I created two physics materials and set restitution to 0 and tried both in mesh and capsule component of both characters.

Sidenote: How did you get your ue4 to look like that, the colours are clean haha

I’m using UE5. :wink:

1 Like