Help Please!

I have made a few small mods and was able to get them working, so I decided to try something a bit more difficult. I made a new industrial grinder. the default craftable items are thatch and flint. I added to the craftable items charcoal, gunpowder, spark powder, narcotics, cement paste (chitenpaste) and stimulant. The only items that craft are the 2 default items (flint and thatch) and charcoal. All the additional items light up when I add the resource requirement, but they do not craft. I have spent I don’t know how many hours changing different settings to try to figure it out, but I am missing something.

Thank you in advance.

The resources that aren’t crafting have a “crafting requires inventory component” - are you creating new blueprint files, or adding the originals?

I tried copying the originals, I tried saving them as children. And I tried making a custom resource. none work.

I made an industrial grinder that does flint/thatch at 5x speed, and I decided to add fiber to this. Fiber doesn’t naturally have a crafting requirement (as in it cannot be crafted), so all I did was this:

Create child of Resource_Fibers
In said child, enable “IsBlueprint”
Add Fibers_Child to MY PrimalInventory_IndustrialGrinder_Copy
Turn it on, worked fine

Try to isolate the differences between the two that worked and the ones that don’t work.

I did the exact same thing with charcoal. I add wood to the grinder and it makes charcoal without a problem.Same with flint and Thatch, (default items) they both work fine. BUT, the others do nothing. The only common denominator between the ones that work (flint, thatch, charcoal) is that they all take 1 resource, while the resources that do not craft (gunpowder, spark powder, narcotics, cement paste (chitenpaste) and stimulant) All take 2 resource elements to craft. That is the only difference I can find. I know im missing something simple, just cannot find it.

There are two other differences - the ones that do not craft are engrams. You have removed “Requires Crafting Component,” yes? It’s something you haven’t clarified on.

I have removed it requires crafting component, and replaced it with my mod component. Should that say “none”? As far as the other items being engrams. Should I check is engram instead of is blueprint? Sorry, I am not a programmer, am new to this, and am trying to teach myself using videos and reading the forums.

Leave it as “IsBlueprint” with no required crafting inventory. Make sure the default engrams in your inventory are properly set as well. There should be a setting either in the item or in the inventory about “allow remove from inventory” you can leave this false so you can test it in your inventory vs in the grinder

I figured it out I think. The kid in the video said to delete the inventory in the file with the dark blue strip (storage box file), and replace it with the Primalinventory_BP file. I can craft fine if I DO NOT do this. its when I do this, things stop crafting. So, as of now, it is working. BUT, that is without replacing the inv in the storage box file with the primalinventory_BP.