Download

HELP Please with my first simple torch mod

I have done plenty of modding over the years but nothing for any Unreal engine game and thought I would try my hand at a simple (HAHA) mod for ARK. I spent the whole of yesterday messing about with this without success. So I started from scratch today making notes to help identify what I am doing wrong. The mod is supposed to remove the need for fuel from standing and wall torches, for now I am just interested in getting the standing torch to work.(I wanted to replace existing rather then add new ones)

This is what I did today…

  1. Created the mod folder, copied over PrimalGameDate_BP_ GenericMod, TestGameMode_ GenericMod, GenericMod and renamed them accordingly.(only changing the GenericMod part)
  2. Loaded the renamed empty level and set ‘Primal Game Data Overide’ and ‘GameMode Overide’ in World Settings to point to the new files. (save)
  3. Copied the PrimalItemStructure_StandingTorch and StandingTorch BPs to the mod folder and renamed them.
  4. Edited the new StandingTorch BP to remove fuel, changed the ‘Consumes Primal Item’ reference and removed the Inventory. (compile & save)
  5. Edited the new PrimalItemStructure_StandingTorch BP, changing the ‘Descriptive Base Name’ and ‘Structure to Build’. (compile and save)
  6. Edited the new PrimalGameDate_BP, setting the ‘Mod Name’, ‘Mod description’, Remapped the old torch to the new (PrimalItemStructure) and added the new PrimalItemStructure to the ‘Additional Structures to Place’ array.(compile and save)
  7. Test in Editor – works perfectly. :smiley:
  8. Cook using ‘Cook Game Mod’ – Takes a long time, considering we are just changing a few files and compiles without error but with 701 warnings. :confused:
  9. Upload and subscribe.
  10. Test in game - the mod shows as a map. DOH! :mad:
  11. Changed ‘Default Game Mode’ in PrimalGameDate_BP which I forgot in step 6. :o (compile and save)
  12. Recook and upload.
  13. Test in game - Same as 10! DOH! :mad:
  14. Edit my level to force load TheIsland.
  15. Recook and upload.
  16. Test in game - Same as 10! DOH! :mad:
  17. Unsubscribe and delete mod folders from ARK. Re-subscribe.
  18. Test in game - now shows as a mod. :smiley: but does nothing. :mad:

So what am I missing peeps?

Any help would be much appreciated.

Regards,

Les

So it would seem that the ‘Remap Items’ doesn’t work the way I would like, in that it won’t replace existing items. I was trying to avoid duplicating items, but it seems I have no choice. The mod is almost working perfectly when I add new engrams. The only problem I have is that the new Wall Torch is not craftable in existing smithys, you have to build a new one.

Regards,

Les

Remapping should have worked, did you have your mod at the top of the load order? But I’ve also had this issue too just trying to add new craftable items to the mortar and pestle (without modding it, just using the add additonal structure thing (can’t remember the exact one but you pick a structure and can add things to it))

Have you tried crafting a new torch and placing it? sometimes existing items (already placed before the mod) more or less don’t get updated

Les that is correct - you cannot add your new items to be crafted in existing inventories. The only way around it (that I am aware of) is to either:
a) allow the player to craft the item in their inventory; or
b) create a custom crafting bench that has your item as a blueprint that can be crafted within it.

Hope that helps :slight_smile:

The standing torch worked perfectly in the editor and standalone game when run from the editor. It didn’t work at all in the full game on Steam and it was the only active mod. It did nothing for existing torches or newly placed ones. I only got it to partially work when I added a new engram and remapped it, but again it didn’t change existing torches.

I was hoping the the ‘Remap Items’ would replace existing items already built, but either that’s not possible or it’s broken.

I think the ‘Additional Structure Engrams’ array is supposed to allow you to add engrams to crafting stations easily and either I am missing something stupid or it is broken. (The fact that items appear in new Smithys and then disappear makes me think it is the latter) I didn’t really want to change the way things are crafted or add new stations if at all possible.

Regards,

Les