Download

Help please the latest update broke my mod..inventory items are disappearing

Hello folks,
My mod Research and Development has been working fine for 3 months, but after the latest update to the game all of the recipes in the inventory of the structures are being lost when the game is restarted. When the stations are first placed everything is in the inventory as normal, but when the game is restarted or server restarted all the inventory items are gone and the slot count shows a negative number equal to the number of items removed. Now the questions, What has changed with the structure inventory system? How do I go about fixing this problem?
Thank you,
Tom

I fixed it thank you anyways.
Thank you,
Tom

Rather than just saying you “fixed it”… you could provide the cause of your issue at the very least - if not your solution - so people that search for this issue can perhaps fix their issue without creating more and more threads about the same thing.

-WM

I agree with Woeful. I’m having the same issue. Could you please let us know how you fixed it?

Hello Folks,
Ok… I want to start by saying out of my 50+ posts very few have been questions of those 0 have resulted in actual useful support, so there is a real problem with the forum. I the spirit of changing that here is the solution there was a new flag added to the structure inventory blue prints called ‘Force Item Non Removable’ set that and it will lock the inventory. I hope my support is helpful to someone.
Tom

:frowning: that is already set on mine and the items still gone after reboot thanx for the info, I’ll keep looking

Haven’t even tried to do anything like this but I appreciate you telling how you fixed your issue. I’ve been responding to my own issues if I some them cause its hard to get help and search doesn’t do much as you see questions and no answers… leaves you wondering if they figured it out or gave up

i`ve a similar issue with my mod.
I fixed it editing server settings -> engine.ini