[HELP] Player Input and Pawns tutorial.

Hi all,

Just gone throw the “Player Input and Pawns” tutorial but the pawn does not seem to AutoPossessPlayer.

Looking at the level as I hit “play” I see that it contains an instance of the DefaulPawn, which apparently is receiving movement inputs. Is this my problem? How do I stop default pawn from being created when using c++ project?

hm… this seems like I need to look in the game mode direction but I am getting one of those ‘blank’ moments.

Thanks for helping me to get through my first days with UE :slight_smile:

Did you make sure you set your Pawn and Player controller in your GameMode, and make sure that the game mode override on the World Settings (or your game mode is set as the default in Preferences)?

That’s probably what I am missing out on. GameMode shows default pawn and player controller and it looks like it can’t be changed when using a c++ project. The tutorial does not mention anything about how I do that so thats why I am confused.

What do I need to do to change that? Is this in some later tutorial?

Thanks for help.
e145743dfca1282e59c632856efb174593a9b79c.jpeg

waaaait a moment… just as I was reading your answer I went in an played around with it and what do you know it actually works just fine… maybe I was too tired last night and did not notice that I did not put it into a level and assign a mesh to it… thanks :slight_smile:

No problem I’m glad its working for you!