Download

[Help] PhAT Collision Out of Bounds

Hey folks - I’ve been headdesking over this problem for a few weeks, read through some documentation and really at my wits end here.
I’ve created a mesh using Makehuman [Autorigged using the xonotic bones] , edited it for some materials, checked the weights and skin in WebAnimate (works fine, can even retarget .bvh files to it with a few pose tweaks)

However, when I bring the .fbx into UE4 PhAT seems to have some major issues with it (or I’m missing something on the tutorials)
If I auto generate the physics body the following behavior can be seen in when I examine the model in game:

I went into PhAT and saw the following, so I then deleted the jumble of physics bodies

With no physics bodies the .fbx causes no issues, animations seem to work, etc, however as a test I put on one physics body(tried both syphil and box) attached to the hips bone, scaled it to size and the following happens:

The character isn’t flying, it’s floating there in mid air resting on the collision body which behaves normally even though the bounds of the collision barely exceed the size of the model. I know that I have to create a chain and attach them through some pain staking work, however am I going crazy here or should this not be happening with one scaled collision which doesn’t extend past the model mesh? Thanks in advance.

Also, this is the physics body which has been attached to the hips bone. Not sure if it helps but the hips bone is one under the root bone.

Hi Trey,

What is the behavior when you hit simulate inside PhAT? A useful command when running the game is show collision.
If you attach your skeleton, skeletal mesh, and physics asset I could take a quick look.

Have you tried these tutorials?

Here’s the .fbx of the character. I have gone through the tutorials.

Application of the physics simulation results in, by default physics model, goes spastic. Just adding a scaled syphil (post scale tool) results in the same physics as you see above, a topple over and static position. I’ve tried attaching a syphil and box to the head and legs, resulting in the limbs going flying and stretching. It seems when I attach something and don’t scale it, it fits better, but I can’t see it…

(thank you for the reply!)

Got the Skeleton & Physics exported, thank you again.

Hi Trey,

The problem stems from the fact that you have bone scale turned on (10x). I’m going to check with someone if this is something we actually support, but it looks like PhAT currently does not.
What ends up happening is that the rendering code in PhAT is ignoring the 10x scale, but the actual physics code uses it.

When you run the game if you use the command pxvis collision you will see what the physics engine actually sees (which in this case is a very large capsule/sphere)

Would you be able to change your bone scaling to 1? I’m pretty sure bone scaling is not supported right now, but I’m going to double check to make sure it’s not just a bug inside PhAT.

Please let me know if you have any more issues. Sorry for the trouble

Hey Ori! Thank you so much for your help. It seems the fix for the problem is 3 fold. Here’s the workflow that I’ve established that seems to work:

From Makehuman: Set export scale to centimeters
KrmOwbX.png
Import options into 3ds Max: Manually set scale to decimeters
6t7P68L.png
Export options from 3ds Max: Autoscale to 1.0

This seems to have worked, both for direct import from Makehuman->Max->Unreal and Makehuman->Max->Webanimate->Unreal.

Glad you found a workaround. I talked to some people internally and we’ll be adding a fix for PhAT so that this isn’t a problem in future updates. Thanks for bringing it up

Hi All,
WebAnimatewas updated to export the scale properly, previously we had some units conversions which was not applied correctly
on some models but the latest version resolves this.

Thanks