HELP - No changes to my storage item and now it crashes to desktop

I have a simple modded storage box with text render component added. It has worked for years. It was working on Dec 22nd. Then on Dec 25th, if I attempt to place it, not even clicking but still in the green ghost, I will crash out to the desktop. I didn’t make any changes to the mod at all. I tried to reverify my dev kit files and cook it again but it is still consistently crashing with any attempt to place this item.

I can confirm the crash in both my server and single player but not in the dev kit. This makes it hard to debug!

Any idea what could have changed with their 23rd patch that might have effected a modded storage box?

Also another one of my mods won’t even load and simply crashes. This mod has been working fine for a long time too and I made no changes. I just don’t understand what could have changed to mess with existing mods so badly. Any clues would greatly be appreciated. :frowning:

Ok I just got a reply from Zen Rowe. It is a known issue about the text render component. Here is what he said about it:

Zen Rowe

I am aware of the issue. Once someone that can handle it is back from the holiday break I will become very annoying until they look at it. Current workaround for mod authors (if you can’t wait) is to make the text component non-visible and make visible only after placement.