Download

Help needed using ReverbVolumes!

I’m having a lot of trouble simply applying a low-pass-filter to sounds when the player enters a reverb volume. I’ve edited the ‘Master’ Sound Class in the Sound Class Editor to have ‘Apply Ambient Volume’ to true:66ab990907c6412e3d0bb47e2c9d0adcad68ff94.png

When in the Reverb Volume, many sounds work fine (such as gunshots), however certain sounds (like all sounds played via AnimNotify on my player’s arms (so all my gun handling and reload sounds) play with no low-pass-filter.

Does anyone know why these certain sounds aren’t affected by the Reverb Volume?

Or is there another simple way to apply a low-pass-filter to all sounds in the game (through the AudioDevice)?

I’m open to any/all suggestions. Thanks :wink:

hard to say. for me reverb volumes work (or if it something doesn’t work, I never noticed)

do the unaffected soundcues have an attenuate node with the spatialize option enabled?

Thanks for the response Chosker. I’ve just done some testing and the unaffected soundcues work when they’re played from my third person skelmesh (via AnimNotifySounds), but not when played from my first person arms (also using AnimNotifySounds).

After some more testing, I’ve determined that the anim sounds that ARE being affected by the LPW on the reverb volume are one’s that are going through a custom AnimNotify_Scripted that I added a while back.

So it seems that sounds played through AnimNotify_Sound (triggered from a skeletal mesh anim) don’t respect the ReverbVolume. Interestingly they do get slightly affected when the player is bobbing on the surface of the Water/ReverbVolume.

Is anyone else able to get AnimNotify_Sound’s (playing on their pawn) to be affected by ReverbVolumes? I’d rather not have to replace all of my AnimNotify_Sound’s with my own custom one.