Download

Help needed: Translucent slushy snow

Hi everyone,

I’ll cut straight to it.
I’m porting a scene from UDK over to UE4 and I had a snow shader that was set to translucent so that I could play with the opacity whenever the snow intersected with other objects.
It gave it a nice wet/runny effect.

Now in UE4 setting it to translucent lights the whole object up as if it’s being lit from another world!
I can’t find a way to not make it glow. I can’t think of a way to get anything to have a soft alpha for that matter.

Has anyone figured out how to get a soft masked material or how not to make anything translucent glow?

Here’s what it looked like in UDK

And here’s what’s happening in UE4:

As you can see, the objects with the snow shader on them ‘light up’ after being set to translucent. It’s as if translucent and additive are the same thing (they look identical btw).

I really liked the effect and any help would be greatly appreciated.

Can you try multiplying your translucent mask or areas of it with a constant lower than 1? like multiply the mask with 0.5 and go lower until you find the right value.

That the only thing I can think of as i have no idea whats your material actual setup.

Hi, thank you for your answer.
I’m running a DepthFade node into Opacity and have a constant set to 1 going to opacity and one set to 10 going into the FadeDistance.
I tried multiplying the result with values ranging from 0.1-10 and it just affects everything equally.
Any value under 1 will turn the whole object transparent and anything over 1 gives me the result posted above.
Right now I’m thinking this must be a bug as setting the Blend Mode to translucent or additive gives me the exact same result.

You might want to see how they set up their snow in the example assets then, In the FX cave they got some examples of snow and ice. In beta at least they looked to blend well.

:frowning: I’ll have to wait for the FX cave content to become available then.
It’s in the coming soon category for now.

You might be able to check some of the pre-made functions in the editor folder in your content browser.
Or there might be someone that can help you more than I am by trying to replicate your issue. I am not a modeler unfortunately it would be hard for me.

Have you tried using SSS for the snow instead? There are still issue with lit translucency in UE4. T put it quite frankly it’s actually no good at all. Epic will probably address this in the future but for now what you see on your screen is as good as it’s going to get for the time being. But using the SSS shader for the snow I think would work and give you some really cool light interaction. I also think that is how Epic did it in the Elemental Demo.

If you do try out the snow with the SSS shader do not forget to set your Lighting Mode Subsurface and also remember the your opacity controls how much light “Gets Through”. In the content example there is a very simple SSS shader example that you can look at to get the basic idea of how it works.

Heya Nomad,

On the main material node, in the Translucency Category, try adjusting the Translucency Lighting Mode to TLM_Surface. Just note that Translucent materials use the Forward Renderer and not the Deferred one, so they will look different, but the TLM_Surface mode is about as close as you’ll get and still be able to use the depth fade.

TLM_Surface.jpg&stc=1

You can find more about it here: Lit Translucency

And Samsterdam’s suggesting to add SSS is a really cool idea, it’ll allow the light to appear to scatter within the surface, being more snow like =)

Thanks for suggestion guys.
It’s already set to TLM_Surface.
If it’s part of a forward rendering solution, would I have to rebake lighting before I see the results?