Download

Help needed - On actor clicked, go to certain location... character doesn't move at all


Note the origin/pivot point down in the left, mesh is part of a group of meshes, placed billboard at top of stairs for vector target in simplemoveto, works ok, lot of other issues, but this will do. increased navmest to 5x5x5 , removed redundant second navmesh, adjusted recastnav to allow for custom stair slope and step height.

That’s nice but I was not going to send the character upstairs. :slight_smile: I need it to go front of the stairs when I click on the stairs or any other ground location I feed it, but it does not move.
So I think the problem still stands. :\

https://www.youtube.com/watch?v=P6mf1p9K2Cs

Yes, If I create a cube in that BP it is created in 0, 0, 0 for me too. But the 'Simple Move To location node is getting ignored no matter what location I give to it inside nav borders.
Even after I created a new single big navmesh in origin. Everything gets executed after the ‘move to’ node (rotation, play anim…everything) but the moving does not happen here. Maybe there is something corrupt in the scene.

make a new project and test, that’s all I can say to help lol

The only thing I can think of is you maybe confusing blueprint origin with level center coordinates?
The reason the cube is added way down in the blueprint is that the stairs where modeled as a bigger piece, and for placing them they will all have the same origin point(pivot point).

That point when placed in the scene is 224 below the street surface, well below your original navmesh.
Make a new 5x5x5 navmesh that covers the street and stairs with green.

place an object like a cube inside the scene where you want the pawn to endup, ensure it is above the green area.
copy the location from the outliner panel and paste it into a vector variable, (yellow one) and connect that to your moveto location, Then delete the cube from scene, this will work,

that was your project in the video, if this doesn’t work, start watching all the official unreal videos from the beginning.

Thank you, but it’s not about the cube anymore. :slight_smile:
The cube I used before in the BP was already moved to the correct location in the scene. I placed there a separate cube also, they had the same coordinates. I converted the mouse click from screen to world location, printed it to screen and it was the same location as the cubes. I fed this location separately as a variable into the ‘SimpleMove…’ node. Tried different location coordinates also. Does not work. That node is being ignored. Everything that comes after that node is executed but not the move node.

Slow walk through of your project, from broken to fixed.

https://www.youtube.com/watch?v=bD3UUmko1LA

Ah man, you are spoiling me! :slight_smile:
I’ll watch this today, thanks!

By the way, this is the WIP project ‘we’ are working on :smiley: :

https://www.artstation.com/artwork/qAox6R

This worked indeed, thank you! :slight_smile: