Help ! Need my triggers to trigger off ONLY when I walk into the trigger.

The subtitle dialog triggers are all triggering off all at once as soon as I start up the game in the editor.

Not what I want.

The NPC’s are carrying the On Overlap triggers on them as a sphere component. But I want only just my player to see and activate the trigger.
I don’t want all the OTHER NPC’s setting themselves all off each time they run into each other.

There are a few different ways you can deal with this:

  • Modify your collision channels so that only the player will trigger a collision with the sphere components.
  • From the overlap event, take the out actor reference and try to cast to your player class. Only show the subtitle dialog if the cast is successful.
  • Set up an interface to show the dialog and make it so only the player implements that particular interface.

Yes I found the Collision Sphere Preset settings. Now which one of these settings do I modify to allow only just my player pawn to trigger off the collision of
the sphere components and no other pawn to trigger them? Because this will have to be changed on every single sphere collision that my NPC’s are carrying and that should stop the triggers from setting off all at the same time.


Question, should just only the main text dialog be put into the data table, or should also the choices and consequences options text be put in
the datatable along with the dialog row entries as well?

Because according to this Dialog Struct node it looks like to me we have to put everything into the same data table that is related to the dialog…

Adding to the ausernottaken’s list, there are also tags.

This dosen’t answer my question about the settings I need to change.

A new collision preset should be created for your sphere components and another for your player capsule. You can do this from the Collision section of your Project Settings:

The preset you create for your sphere components needs to be set up so it ONLY responds to the preset you created for the player capsule (overlap response). The preset you create for your player capsule should be set up to respond to your sphere components (overlap also), and have the appropriate collision response for everything else (collide with solid geometry, ignore Visibility preset, etc). To assign a preset to a component, you can do so by selecting the component and going to the Collision settings under the Details pane:

So I have to create two new collision presets in the project manager in order to get these new flags to show up in the blueprint under the collision presets flags ok.

These are my settings.

IN MY PLAYER Blueprint or third person, my Capsule Collision its set to use Pawn for the Collision Preset, and the Dialogbox trigger component is
set to use OverlapallDynamic collision preset.

Now in my NPC Blueprint. The capsule is using Pawn preset for the collision and the collision sphere component is set to use
the Overlapalldynamic preset.

That’s the set up that I have at the moment using the default presets in the engine.

Looking at your screenshot I do not know if BLOCK ALL is the new preset that I need to create since there’s already one in the list by
default under that name. or it BLOCK ALL just there as a default example??.

Umm without the blueprint type and actors components shown in the screenshot I can’t tell what blueprint or actor the screenshot is coming from !!

I also need to know what the collision flag settings are for these two new collision presets that i need to set up in the project manager because
I’ve never set up custom collision presets flags before, I’ve always used just the default ones in the list that came with the engine.

The other thing I do need to know if someone here does know, is do I need to put my Choices and Consequences text Options also along
with my dialog text in the data table or can the decisions Options text be put into a separate data table?. Because when I
look at the Dialog Struct Node, it appears to only allow ONE Datable to read everything from.

Or can I just simply shove all the choices options text all down at the bottom of the same data table after inputting in all the bulk text dialog?

Sorry! I missed a step.

You’ll need to create an Object Channel for each, as well.

The Default Response is simply the default response that newly created and existing Object Channels will have to this channel. The Default Response for NPCInteractSphere is set to Ignore because we want all existing and newly created channels to ignore this one by default. The Default Response for PlayerCapsule is set to Block because most channels are going to be blocking this one. All this setting does is minimize the amount of flags we have to mess with later.

Now create your preset for the sphere components with settings similar to the ones below:

The CollisionEnabled should be set to Query Only, since all this will do is trigger overlap events. It will never collide with anything. It should ignore everything except for the PlayerCapsule.

Here is how your player capsule settings might look:

We want this to overlap with any sphere components, so we set its flag accordingly. Capsules are invisible, so they ignore the Visibility channel. We also want projectiles to collide with character’s mesh instead of the capsule, so we ignore the Projectile channel as well.

Now you want to open up the player character blueprint, select the capsule component, and assign the PlayerCapsule preset as its collision preset. The same thing will be done with your sphere components in your NPC class, with the respective preset selected.

Thanks for showing the full screens now i can see where its coming from

Okay I done the object channel and the presets but it hasn’t resolved the problem. The pawns still fire all their triggers when starting game.
Now creating that new object channel along with those 2 new presets has now upset all the collision triggers for the doors in my level, now the doors
are blocking the player off and won’t let the player through the door…

The solution to stop the pawns from triggering off and only the player uses the trigger requires some Blueprint Logic but it don’t stop them all
doing it right at the start of the game, but it does stop them from triggering each other off simultaneously after that. And that is to drag from the
actor pin on the on overlap component and type two equals, then attach one input pin to get player character (not pawn) but your player character.
Then attach the boolean end of it to a branch and then connect it up with the Play Dialog.