Help nave Bounds volume

Help Nav Mesh Bounds Volume

Can anyone help me solve this error in Nave Bound volumes does not look green. I already pressed “P” please [1]:

Have you set a collision on your mesh?

![alt text][1]
already has everything

I assume that you can’t navigate though. I am no expert here but this is what i’ll do and I’ll show you from one of my projects.


1- check the collision on your mesh. It means double clic on the static mesh you’re using in your asset and check if it has a collision box. If not put one, save and check if now you see the green navigation area. (having the Collision Presets set to Default does not mean your mesh has a collision box).
In my example my mesh Piscina in the Mesh editor you can see that I have a collision box (cause I ve selected the collision button on the menu and when I clic on the mesh i can see the transform of the collision box and its outline)

2- check your collision settings on the mesh, and try Block all


3- Delete your nav volume and the RecastNavMesh objet that comes with, and throw a new nav bound volume.


Hope i helped.

thank you so much!!