Download

HELP! Mods uploaded fine but not affecting the game...

When I test and upload my game-mods everything is fine, I can choose it in the game’s menu but then- in the game, there’s no trace of them… oh why? 8/
Any ideas, mates?

did you map your changes?

can You please explain what do You mean by it?

Milo, is this for singleplayer or for multiplayer?

did u make sure its all hooked together primal game bp’ gamemode bp , and its hooked to the level

Well it’s all set and hooked to PGBP, and there’s the gamemode file and the third ‘orange one’…:} but I dunno what else shloud I do with the last two. (I wanna make a mod without attached map)

And it doesnt appear in game- both SP and DEDI-server (works on editor’s tests great though)

EDIT: Ive got this figured out now; thanks for helping , good people :]

Can you explain what you did? Because my mod isn’t showing up in my SP game.

You have to make sure to follow the stickied tutorial on “how to make a mod” pretty much exactly as it is done.

Okay, I’ll check it out again, thanks.

https://forums.unrealengine.com/showthread.php?75713-Tutorial-Creating-a-core-data-Mod-%28Not-a-Map-just-a-Mod-%29 This is the tutorial I was referring to by the way. I don’t mean to be rude or anything, it is just much easier to watch this video and follow along than it is for me to type out the entire process. Especially when it’s already done :wink:

It’s totally cool, I’m sure you guys have to answer the same things over and over again and it’s gets tiring.

A quick and easy way to start, if you have generic mod and have not altered it, duplicate the folder and mod files, rename it. [If you edited Generic Mod and it’s gone, or changed, verify your installation and it will be reverted to original]

open the GenericMod level file [the orange one that says level, double click it]
click window -> WorldSettings
Change the Primal Game Data Override to your Primal Game Data file [yes it HAS to have primal game data in the name]
Change the Force Load Map Name to TheIsland
Change GameMode Override to your GameMode file
Double click your PrimalGameData Change the name to something, add a description.
And change the GameMode in your file to your game mode.

SAVE ALL [do this, seriously do this, if anything has an asterisk it means your changes are not committed to file and will be ignored by the cooking process, they may not even be written to file]
SAVE ALL [yea do it again, paranoia is healthy… just do it]

Cook & Upload.

You will be able to see it as a mod, and you will be able to load it, if the name is changed to yours, and the description you didn’t miss a step, now go add stuff to it.

Once you know you are doing it right, change the TestMap Levels world settings to your PrimalGameData and GameMode and test it all in editor [but editor will let you do more then the game will it doesn’t have true error checking]

Hello Survivors, I had a very similar problem where my mod worked fine in the editor but the cooking and uploading never effected the game. I ran across another post here about problems cooking the mods it really had nothing to do with me, but did get me to check my cooked files to find that I had nothing more that just stubs of 1k and such. I figured out I had a typo in the map name (the one I copied and renamed from generic mod). The cook and upload process looked successful with no errors or anything but no data was written. it uploaded to steam and imported to game but was completely empty. Check your map name is a good easy solution. Thanks, Tom

P.S. - If you haven’t gotten any mod working do as TheRealAzrael suggests and follow the tutorial a step at a time to get one working then try to move on from there. Just wanted to throw out a word of caution on the lack of error checking in the cook dialog. Cost me several hours of checking and rechecking my files thinking I had screwed one up when it was I simple typo at the very end.

This worked! Thanks a bunch, now I can really work on my mod knowing how to make it and get it to work in-game. Again, thanks!!

That can definitely lead to an error also. I spent days looking a reason why my mod wasn’t “cooking” properly… turned out that in my level map, the PrimalGameData and TestGameMode references had somehow been turned off… it’s usually something very simple, you just have to patiently search for it :smiley:

Best Tutorial. Follow it to a Tee. Worked wonders on my headache! I will be starting every Mod this way just to insure it will load before I spend days building something with errors from the start.

You actually don’t have to forceload “TheIsland”, you can leave that blank and it will allow people using your mod to still choose whatever map they want. That way your mod can still work with custom maps!

They change that did the Azrael? It used to just load the black emptiness of despair before, although that was tested in singleplayer… which is a lonely pit of nothingness to begin with, I guess it’s the server that forces it to the map if I think about it.

They changed the way the mod translates. If you cook as a mod, the game knows that the mod is not defining the map and picks the map for you. Thats why they only use the “MapModID” command line for servers if the mod is a map. If it’s just a normal mod, it is now “ActiveMods:”

Alright – I have done everything forward and backwards to get a mod to work in-game. It refuses to do so. Works great in the Editor, etc. but once uploaded - nada.
Perhaps there’s a major change in the difference from the actual game 206 and the 201 we’re working with that keeps them from working? I know there’s a TON different between the only video tutorial (185) and now.

Things I’ve Tried:

Setting the Primal Game Data Override.
Setting the Game Mode Override.
Linked Engrams and Items Correctly.
Cooked, Baked and Buttered the Darn Thing.
Deleted Everything From the ARK Mod Directory and Re-Downloaded.
Re-Uploaded After Deleting It From Steam.
Followed the Video to the Letter T.
Followed ALL Examples of Fixes From Above.

And For Goodness Sake, it’s just the DEMO MOD from the tutorial. I’d REALLY hate to see what happens when a REAL one is put through the pipes.