Download

HELP ME PLEASE!!!! PackagingResults:Error: Error Unknown Cook Failure

I’ve attached the crash log in a text document down below, I really need help with this since I’ve been having these problems for months and I’ve tried almost everything I could think of, please help

The only errors I can see from the logs is to do with you’re u map file for the level. It says it’s either corrupted or missing . When you packaged did you add the map to the packaging maps array?

No, I’m not really sure with that is anyway, I’m still a UE4 novice. However, I am aware of .a map that may be corrupted within the content files. I haven’t been able to delete it in the editor though. Whenever I try to delete it, it says “Failed to load assets”

@Breakerbomb

  • be sure to look in your settings to see which map you are telling the editor to ‘Load’ *

the editor looks for whatever map is listed there & which to load to start with. if you created a new map just use it’s name.

** also if you don’t have much work done or can migrate it out into a new project, that might be your final solution until you can figure out what you did **
( also -> always build then ‘Save’ ! A Lot! )

@ayretek

Alright, but where exactly can I list them?

@Breakerbomb

have you looked at the Documentation for Unreal? I don’t know how knowledgeable you are about Unreal Engine 4, so no insults intended. :slight_smile:

https://docs.unrealengine.com/latest/INT/
I think a lot of people don’t even realize it’s there, lol.

of course i’m not sure that’s your exact problem but often people either create new maps etc (or moved them) and forget to tell the editor which level or map to load on startup was what I was referring to.
(what I was referring to (as far as maps or levels) can be found in your project settings (either under edit or at top of your viewport) under maps & modes in the project settings

but finding packaging errors can be difficult but it seems you are trying to actually Package without building - cooking etc. &/or have moved some of the files used for this.
if you are unfamiliar with Unreal Engine that much you should really start out simple - maybe by following some simple examples in the documentation
but you have to do certain things before actually packaging a game or it just won’t work. & actually other than testing at the end of your project, packaging is almost the last thing you do before you publish your game.

but to try to help, you will find a lot of help & info on getting started on Unreal’s YouTube channel for instance as well as the Documentation mentioned above: https://www.youtube.com/user/UnrealDevelopmentKit

OK to fix this in the content browser in the editor right click the corrupted map and there should be an option “show files or folder in explorer” this will open up the folder directory of where the corrupted map is stored on the actual computer. Then simply delete it from the folder.

Now close down unreal and reopen the corrupted map should be deleted.

Right click the content browser again and look for an option called “fix up redirectors”

Once the corrupted map is gone . Repackage and let me know how you got on . If not I will try and help you later when I get home and can actually get on my computer . Thanks

@EniGmaa @ayretek

hey guys I apologize for the EXTREMELY delayed response

i tried Enigmaa’s suggestion only to receive another cooking error after a 2 day long packaging attempt. Any thoughts, should I cook it first?

UPDATE: I attempted to cook before packaging only to receive a BUILD FAILED from the logs as result. I’m all ears at this point.

So then, send us the new logs you are getting, since there is probably a different issue now.

Here you go! Thanks for doing all this for me

P.S. I’m kind of totally depending on you guys, no pressure :slight_smile:

Seems like you have a invalid font reference somewhere. Check all your fonts and especially, all references to fonts you got in your UI/maps/wherever, do a “Fix Redirectors” on the whole project. If that doesnt help, try deleting the Saved and Intermediate Folders and try again.

Let me know if that helped.
Cheers,
Indy

Hey @indygoof and thank you so much for responding, I’ve tried it but once again to no avail. Maybe I didn’t delete the right thing but I deleted most of my widgets ( I didn’t really need them now that I think of it) What do I do from here? Any more suggestion?