Help! map specified on the commandline '...' could not be found

Hey! I have a problem with exporting my package in Unreal Engine! When I packaged my game and want to open it, I get a message that says: The map specified on the commandline ‘/Game/Unreal_Oosteinde/Scenes/Oosteinde_Scene’ could not be found. Exiting.

The game Launched perfect when I open it within the editor. Also a standalone game isn’t a problem.
I’ve rebuilt my game and checked everything in my Project settings… what seems to be okay.
I’ve also changed the SimpleMapName in the DefaultEditor.ini
I also enabled the Single Process, but it didn’t solve my problem

I really can’t find a solution.

135613-map_not_found.png

1 Like

Hello,

Have you checked to see if your Default Game Map is set to the correct maps under Maps and Modes in the Project Settings? This is likely being caused by having a map set as the default that either no longer exists or due to a file path issue cannot be found.

Take a look at Project Settings->Maps and Modes and verify that the information for the Game Default Map is set to the correct map for your project.

Let me know the results.

Have a great day

1 Like

Thanks! I already fixed it!

there was something wrong in the Packaging settings. The ‘Directories to never cook’ was wrong. there wasn’t a directory selected, but there was 1 element.

So I deleted that one so there weren’t no elements anymore, and that fixed it for me.

But hey! thanks for your help!

Greetings!

Hello, havin the same problem here, did all the above, but still, the map could not be found…

Common issue to this problem is when you move the map from 1 folder to another it sometimes doesn’t update the default map settings properly.

To fix this simply open your project settings >> Maps & Modes. Change all your default maps to something else and then change them back.

2 Likes

You can also specify the game map on the command line if you choose:

MyGame.exe /Game/Maps/MyMap

More info on command line arguments here.

For anyone else having this trouble following Dave72 suggestion worked for me. Removed all maps and then selected them again and it all worked.

Thanks ! I’ve rename my map fold’s name.So i reset Maps & Modes.

Problem fixed here : The map specified on the commandline could not be found ue4 - YouTube

Problem fixed here : The map specified on the commandline could not be found ue4 - YouTube

Problem fixed here : The map specified on the commandline could not be found ue4 - YouTube

none of these worked for me :confused: any other suggestions by chance?

None of these had worked for me when I had this issue. I figured out that I was accidentally using an Early Access version of UE5 (UE5.0EA) to launch my project from CMD rather than 5.0.2 (which my project was built on). So basically, if you try to launch the game from CMD using an engine version earlier than your project’s engine version, you will get this error.