Download

Help, importing asset as a skeletal mesh destroys the smoothing groups

Hi guys,
So… I’ve been trying pretty much the whole afternoon to resolve this issue but so far i have no success - I’ve been messing around with some morph targets and everything imported really easy in UE4, except for the smoothing groups of the object.Believe me , i saw every thread for the proper settings of the FBX exporter ( tried exporting from 3ds max, Maya, and blender, tried installing various versions of the fbx exporter as well) and the settings of the UE4 FBX importer.I tried importing the fbx again in max, assigning “Edit Poly” on top of the Morpher and Skin stack of modifiers with the smoothing groups again properly set to 25% autosmooth, but as soon as I import again into UE4, they are gone.I tried importing the same mesh i used for morph targets as a static mesh and everything works perfectly, but as soon as I set it as a skeletal mesh, the Smoothing groups just dissapear…Here are some shots for comparison:

- this is the prop imported as static mesh ( and it looks exactly as intended)

c2919c33d2cafa3c67c31a7e77720b8e0b9e48f0.jpeg – and this is what happens when i import it as skeletal mesh ( the proper Smoothing groups just dissappear)

and the nail of the coffin is that for static meshes that is ussualy resolved when you click “Recompute Tangents” or “Recompute Normals”, in the Build Options under the LOD0 properties of the mesh, only there are no Build Options in the mesh properties when the mesh is Skeletal…

please, any help would be greatly appreciated ! I can’t believe that the actual making the morph targets and animation proved to be the easiest part of the process ( compared to fixing up the smoothing groups)

You wrote, “Believe me , i saw every thread for the proper settings of the FBX exporter” but you did not specifically say that you included smoothing groups when exporting selected object from Maya (version ie. 2014.) Try exporting with mesh and bones selected, no IK handles, with “include smoothing groups” enabled in the fbx exporter options. If you’ve already done that with this mesh, try it with a brand new, similar but less complex model and see if you have any success. This will isolate whether it’s a problem with the Engine import, export process or with the mesh itself.

Yes, I did enable “preserve smoothing groups” in the FBX export options in Maya and in 3ds Max and all that :slight_smile: Nevermind , I’ve found a workaround which is not the best option but in this case works - when i exported the mesh from max, i clicked “Split vertex per normal” ( which increased the vertex count a LOT ) and then enabled " keep overlapping vertices" in the UE4 fbx importer options…

Check on your import settings and make sure that normals “Import” and doesn’t calculate or something else.

0ba31d7564304015bb7115d3852d4d86dfa299b7.png

Make sure the option highlighted in this image is set to “Import Normals” or “Import Normals and Tangents” That should use your normals instead of calculating them on import.

Hopefully that will sort out your issue :slight_smile:

Benn

I tried and tried but ‘compute normal’ didn’t work, I’m using 4.20.3 version, anyway, I found what it finally solved it, I have to admit that it took me like 1 month to solve it. cuz I let the project for a time for the strees that caused me, but finally I found the solution and it’s easier that I thought.

In my case Static Meshes worked ok but Skeletal meshes was really bad, then if this is your case and compute normals doesn’t work for you, choose ‘Import normals’ and under Normal import Method there’s another option called ‘Normal generation Method’ probably there you have choosen ‘Mikk TSpace’, change that for ‘Build In’ and click on Import. This finally solved this issue that was really stressing me so bad.

Hope this help you too and sorry for my bad english.

Regards, Rai.

Using 3ds Max there are time when the smoothing groups can become corrupted assuming that you are exporting with “preserve smoothing groups” is checked. This is a typical problem if you imported the model from Blender in the first place .

To fix