HELP! I'm trying to import meshes into Unreal Editor

So I am new to engine, wanted to see if I could make models to put into the engine. It’s quite possible I skipped a step somewhere and forgot to tick a box or something.

Basically, here’s a rundown of my process for backtracking purposes:

  • Make Model in Sketchup
  • Label all textures with L_[texturename] in case there was conflicts while importing
  • Exporting Component as a .Fbx file
  • Imported File into Unreal Editor
  • My imports with holes in it.

I’m not sure what happened, any ideas? Please help

it looks like your faces normals are flipped(you cant see them because they’re inside out and UE4 only displays the outside of the faces(well unless you set the material to 2 sided but you don’t want to do that with your model)), I am not sure how you recalculate/flip the normals in sketchup but doing that should (fingers crossed) fix it for you.

hope that helps:)

If you can’t flip the normals in sketchup, you could do it in Blender ( Import your model, go into “Edit mode” (Hotkey: Tab), select everything (Hotkey: a) and then in the menue select “Mesh -> Normals -> Recalculate Outside”. After that, you can export your model as an fbx file. Make sure you use UE4 compatible settings in the export menue.

fbx export.png

The “Scale” value depends on your imported mesh…if it’s too big, simply use 1 instead of 10.