Download

Help! First day ever using Unreal Engine!

I’ve been doing 3D design for about 2 years and for those 2 years, I’ve used Unity as my game engine. Today has been my very first day ever using Unreal Engine.
It’s amazing, fun to use, A LOT to it, and I’m really enjoying it.

However when ever I bring a file over, I import a file that was from Maya, as a FBX and there is a issue.
There seems to be like black lines going through all of my geometry’s polygons. And Im not sure what it is.

I looked into it a little it may be the normals in maya? im not sure.
I have even looked it up online and have yet to see much about it.

On them model it’s self, I did smooth out edges and I then harden some other edges to give it a look like its a Torch.

Here’s an image to show what I mean.

1c9a660ecaa96285b05a27baf8e6618e6533ea43.jpeg

Please oh the gods of Unreal forums, help me so!
I would very much appreciate it.

Hi Sean! First of all, welcome aboard. Glad to hear you’re enjoying the engine tool set.

Assuming you’re talking about these recurring lines:

http://puu.sh/8LDbl.jpg

Have you tried applying another texture/shader?

The model itself looks fine otherwise that I can tell.
-It’s probably note worthy I’m not a 3D artist, rather a programmer.

When you export from Maya, did you enable Smoothing Groups? You need that option enabled.

Hey Hawkeye,

Thanks for the welcome! I really am thankful and I look forward to using these forums for help and guidance.

No, it’s not those lines. It’s more of these dark lines and darkened out spaces.

And when I try adding a new texture or material to it, it does this!

It only looks none messed up when I change the the view mode from lit to unlite:

ryanjon2040,

when exporting it, I have smooth group turned on.

I can’t tell if it has something to do with normals or lighting or what.

Thanks to you all so very much!

-add a lightmass importance volume and raise your lightmap resolution
-also make sure that you have a 2nd uv channel with a proper lightmaps
-and build your light

Then we know if it was a light problem :slight_smile:

It’s a smoothing problem, make sure to check your import settings in UE4

Hey man first of all welcome to the Unreal Engine 4 Family xD don’t worry I was in the same boat as you when I started using UE4 xD The different story with UE4 when importing your models make sure that they are UV Mapped and preferably also have a second UV Map channel to get the best out of your texture quality, when you import your model just like that, the engine picks up the model’s UV Channel as very un organised so therefore your Meshes appear to be black.

Looking at the export options, did you try the “Smooth Mesh” option also?

It has to do with the normals (not normal maps) when importing select recalculate normals or if already imported open it in the content browser and on the right check calculate normals and hit apply then save problem should be solved