Download

[HELP] error uploading mod to steam workshop

I am doing exactly the same thing i did two days ago, and it is NOT uploading any changes to the steam workshop.

I cook the mod, which works fine. Then, I try to upload it. I get the below and it does NOT upload to steam.
This “status” of the upload goes like this:

bbd99c04ded6dafe74f8b86e2cbc4bcb6924db67.png

I have revalidated my dev kit. --still no go.
I closed steam, cooked and tried uploading (putting in my password fresh every time) --still no go.

the weird thing is, when it types my password in the output it cuts off the first character-- but it did that on Sunday and still uploaded fine.

The mod is NOT ending up on the steam workshop, and the mod file ID is correct in the mod.dbm file as well as the VDF file as well.

This is super frustrating me, because I don’t get why it isn’t working when i have changed NOTHING about what I am doing to upload it.

I also went into G:\Steam\SteamApps\common\ARKDevKit\ModTools\ModConfigs and G:\Steam\SteamApps\common\ARKDevKit\ModTools\Output then cleared them both

when i tried uploading i got the SAME error again

CHecked the .vdf file and it still had the correct mod ID and the same notes etc as before
\SteamLibrary\steamapps\common\ARKDevKit\Projects\ShooterGame\Saved\Mods.db still ahd the ccorrect mod ID

tried manually running steamCMD and got this error:

68c72a09a449fbae55fcf08a696d6ffb3087d6ba.png

It seems that your VDF is not correct.

I don’t know if it makes a difference but there are tabs in the VDF file: “appid” “346110” ( = tab), the encoding is UTF-8 without BOM and the line endings are just line feeds, no carriage return (UNIX, Linux Style).

Can you post your VDF?

Here is the VDF. I did delete it before manually running steam CMD, but it seems to have generated exactly the same way.

I updated the dev kit and recooked/reuploaded… same problem again. This is the VDF file contents after i updated the dev kit.



"workshopitem"
{
	"appid"		"346110"
	"contentfolder"		"G:\\Steam\\SteamApps\\common\\ARKDevKit\\ModTools\\Output\\Dar_ExtraTools\\CookedMods\\Dar_ExtraTools"
	"previewfile"		"G:\\Steam\\SteamApps\\common\\ARKDevKit\\ModTools\\Output\\Dar_ExtraTools\\CookedMods\\Dar_ExtraTools\\preview.jpg"
	"visibility"		"2"
	"title"		"Dartuche's Extra Tools"
	"description"		"Core-mod - Most likely requires a vanilla world & save. Use on existing saves/worlds with caution.

This is the first mod I have ever created. I have play tested it in game and... it appears to function as designed so far.

It adds four items. 

Skinning Knife: 
A specialised knife for butchering and skinning corpses. (gathers a much higher rate of meat and hide)

Sledgehammer: 
A large metal sledge hammer designed to pulverise rocks into useable shards. Unfortunately, it destroys any other resources in the process. 

Hypodermic Narcotic Needle. 
Use this to intravenously apply a strengthened narcotic solution. (x3 times as effective as a normal narcotic, but more costly to craft.)

Stunner Arrow.
Less deadly than other arrows, but rapidly increases the victim's Torpidity. (x3 the torpor effect of a tranq arrow, zero damage, but more costly to craft.)"
	"changenote"		"v1.9
Changed smithy item to "crafting bench" and completely redid all entries to ensure it crafted and placed correctly in game.
Updated all engram entries for hypo needle, as wasn't pointing correctly at the BP for the item.
Updated all items to point at the new crafting bench; updated the crafting bench inventory BP to allow crafting of all items."
"publishedfileid" "488251602"
}


I closed steam, deleted the VDF file and tried reuploading… did the same thing as the initial screenshot.

Sigh… I wish people would use the code tags… :stuck_out_tongue:

It looks fine. Does it still tell you error at offset 1627? There are only 1612 characters. I also have a line break at the end.
Maybe it works with Nex’ ADK Launcer [Release] ADK Launcher - ARK: Survival Evolved - Unreal Engine Forums. The tool creates it’s own VDF file.

Try removing all that extra **** in your description line… and just use a single line with nothing by alphanumeric characters. You can update your description for your mod in Steam later.

I tried the ADKLauncher (which is pretty cool buy the way) but it just uploads a totally new version of the mod every time. i checked the Mod.db files, and the .vdf file, and they both correctly point to my mods steam id.

I did what JasonFJ suggested, and set both the description and the changelog to only a single line of alphanumerics.

It worked! I have to have ONLY alpha numerics in both description AND changelog.

Myself and a few others have had this same problem. I had to resort to using the old Modtools standalone cooker/uploader to be able to upload my mod. Try using that along with changing the ID in the VDF and the mod.db and report back. It’s not a long term fix, but it would temporarily resolve your issue.

JasonFJ and Thurion I just wanted to say a really big thank you for your patience and assistance. This was driving me up the wall and I really appreciate that you took the time to walk me through stuff to fix it.

sinarisinestro – i wiped all the files several times, it just kept downloading my vdf from the cloud i think, as it always regenerated the same. I managed to get it working my setting the description to “blah” and change log to “note” — have successfully uploaded twice now, and I just keep a copy of my description and changelog notes seperate that I upload from within steam.

The VDF file is created by the editor. I think it uses the information from Mod.db to do that :slight_smile:

I did delete the mod.db and .vdf file in one go, then my mod config file too-- i presumed it was syncing with the steam cloud, since after i deleted it all and reopened I got a cloud error about it needing to sync, and then the .db and .vdf files that had been there previously reappeared with the same file contents.

Glad to hear its resolved, but sorry to hear it was not a fun experience…I know the feeling lol

Try disabling steam cloud with the ADK. No reason to have it on honestly.