Download

Help, engine wont open.

i have a subscription, its installed, I hit launch, and it does nothing, im about ready to pull my hair out, please help

Is it really doing nothing? Go into the task manager - processes - and search for unreal engine. When you dont find anything just try to start the launcher with admin rights (right click - start with admin rights) or launch it with a project .exe

It really is doing nothing, none of those solutions will do anything, its kind of terrifying.

Do you use windows or Mac OS and have you already tried to reinstall it? (it’s not the best solution, but in many cases it works). But I would recommend you to post this question into answerhub (with all informations ) :wink:

Yeah im on windows and i did all that, i think im just going to cry, whats answerhub?

That’s the place where you can ask questions about the UE4 which epic games will answer: https://answers.unrealengine.com/

Does your computer meet the requirements?

with flying colors, 16 G of ram and a bunch of other powerful ****, and 64 bit so on and so forth. wondering if its maybe a registry issue from the new install? Tried running CC cleaner to no avail.

ok weird, works on my laptop, doesnt work on desktop, just got desktop fixed, im confused.