Download

[Help] Dino 'AI Move To' always failing - need some help

Hey there,

I need a little help, I’ve been staring at this blueprint all day, banging my head against the desk trying to figure out what’s wrong with this portion of the code:

I’m trying to get the referenced Dino Pawn to move to the specified target destination vector, but each time the code triggers the ‘On Fail’ handler and the dino (an Argentavis in this case), lands where ever it seemingly feels like. No matter what I do, I cannot seem to get it to move to the specified location and as a result trigger the ‘On Success’.

What am I doing wrong? Am I using the ‘AI Move To’ in the correct way?

To give you some more information, this blueprint is for an item that is equipped to the dino as a costume. I get a reference to actor by getting the owner of the inventory and cast it to Dino_Character_BP when the item is equipped (that is stored as DinoChar).

Any help anyone can offer is greatly appreciated!

Are you trying to do something like this? Have the pawn move to pre determined points? Have you tried adding an event being play or any trigger action? i don’t see one there.

Something similar. Yeah sorry, I cut out the rest of the setup as I know that to be working and wanted to isolate just the bit I was having issues with, I now realise out of context it’s hard to figure out what triggers it.

I have something working now, your example gave my brain a nudge in the right direction. I needed to cast the result of ‘Get Controller’ to ‘Dino_AIController_BP’. From there I was able to call the Move to Location function which I believe is implemented in the ‘Dino_BT’. This seems to be working now for the most part.

Below is what it now looks like should anyone else run into similar problems.

I’m still a bit baffled by the difference between ‘AI MoveTo’ and ‘Move to Location’. Why one worked and the other did not. But hey ho. Thanks for your help.

Gald i could help. Some things dont seem to make sense sometimes. like why on the BP i’m working on the npc won’t chase me when “in range” is set to true but i switch it to false it starts chasing me lol im also still trying to figure out how to make it growl once when he sees me but the sound keeps looping no matter what i do.

I’m not sure that this is working actually. It seems like if the Dino doesn’t have line of sight, or gets stuck by an object in world it gives up and lands. Any ideas?

Ok, I swapped out the ‘Move to Location’ in favor of using ‘AI Move To’, this seems to work better. But I do have some edge cases that I’m not sure about:

  • Sometimes the dino seemingly ignores the ‘AI Move To’ and instead eats my dead body (this entire flow is triggered on player On_Died event).
  • Sometimes the dino has difficulty pathfinding around objects and gives up.

Is there something I can be doing differently to account for those edge cases? My code looks like this now: