Help: Cooked mod is only 600 bytes...

I made a tiny map (31x31) and it has been running fine when I play it in the editor or from the editor using Standalone.

I wanted to upload it to Steam Workshop so I moved it to a mods folder using copy and paste through the Content Browser. I cooked it and the first time, it was uploaded successfully but when I went to play it, it would return me to the main menu after the Primal_BP stuff was loaded. I already noticed the file size was really small but figured maybe it is that small since I don’t have any new assets and it’s pretty much the assignation of materials and whatnot.

So I deleted it from Steam Workshop and tried again. Now, it failed to upload after cooking and it’s verifying installation. I checked the folder where the cooked mods/maps are located and found that my map is only 600 bytes.

I didn’t use any new assets, only the ones that I’ve found in the devkit. Does anyone have any idea why it’s so small? Or if I’m missing any steps? :confused:


Okay, so the file I referred to was a .vdf file and not the folder that might actually contain all the cooked files (C:\Program Files (x86)\Steam\SteamApps\common\ARKDevKit\ModTools\Output).

Anyways, this situation where my uploads to Steam fail might be due to the fact that I’ve deleted it from the Workshop from the web browser. I’m guessing the references don’t get updated between the Steam uploader and the workshop.

After restarting my computer and saving my map into an entirely new folder under the mod folder with a different name. I am cooking again. This time though, it’s compiling all the shaders which didn’t seem to happen the first time. The first time, I assume it just used all the shaders that were compiled while painting with different materials. And since I haven’t painted anything this time around, I guess it decided it needs to compile them all. I think this is a good sign because this is mentioned in Kayd’s YouTube tutorial.

I will update again after it’s cooked with how my upload attempt goes.

UPDATE2: It works! :slight_smile:

TLDR; If you have trouble uploading your map (Steam upload failed –> Verifying blahblah), try restarting your computer and saving your mod/map under a new folder and with a new name.

I was just about to respond with “How did you move the files? Through the Dev Kit? Or manually?”. Then I saw you figured it out :stuck_out_tongue:

If you move a mod from one folder to another, it has to be through the Dev Kit, and you HAVE to save all the new changes (new references) otherwise it won’t hold the references correctly, which results in it not cooking out properly.

Becareful with moving mods. Moving a mod outside of the Dev Kit into a new folder structure WILL break ALL references pretty much.

Glad you found a resolution to this quickly!

  • Sinari

Yeah, I did move it within the devkit but probably from all the crashing or whatnot, some references were lost. I also think my video card (Radeon HD 7850) is dying from using the dev kit, it was flashing black and had some horizontal tears when the dev kit was open. Had to restart my comp, haha. Probably time for a new video card… Maybe I’ll upgrade it when I get an SSD for Windows 10. =)

I think my computer can handle the dev kit alright. The hardest part is the shader compiling which I think is actually CPU dependant. I have an i5-3570K which is 3 years old. Personally, I don’t really want to spend money to upgrade my computer just for making maps, haha. But this has been kind of fun so far. I’ll just have to bear with my computer’s performance. I also don’t know if I’ll be able to make a decent sized map by myself. It would probably take me 2-3 months if I worked on it as often as I could.

Map making is pretty intensive all around depending on how crazy you get with it. I noticed that when I upgraded from 16 gigs of ram to 32, shader compiling in UE4 sped up quite dramatically, but then again I also added a SSD shortly before that, so that helped drastically.

I’m running Win10 w/ i7 3770 3.8ghz, 32 gigs DDR3 high performance ram, Radeon R9 290 currently & I’m as of this week running the Dev Kit off of my SSD. Smooth sailing here. My CPU gets maxed during compiling, but I think UE4’s shader compiler was designed to use around 98-99% of available CPU.

If you use your rig for anything job related, then a SSD & new GPU might not be a bad business investment :wink:

I also briefly ran the Dev Kit on an older GPU (Radeon HD7770) and had quite a bit of crashes when doing so. Now, not so much, only really when doing risky blueprinting.

  • Sinari

Unfortunately, my pc is purely for gaming, haha.

It would be nice to get some recommended specs going for the dev kit. We now know two graphics card that will have high chances of causing the editor to crash!

Oh really now? Wow, welp, guess I’ll be waiting to get my second R9 290 till that is fixed.

Where did you hear that/discover that if you don’t mind me asking?

  • Sinari

Haha, I meant the two cards we mentioned in this thread. My own and your old one. :stuck_out_tongue:

Ah-ha! Now I understand lol

Yeah, it seems the older Radeon’s don’t do well with UE4 in general.