Download

[HELP] Complex collision on very big rocks

I just started making a mod, but I encountered a problem:
I need very big rocks with a very complex collision (rocks the size of Dead Island), so I changed the collision of some “UltimateRocks”, located in the assets, so I can walk on it without hovering on top of it. I tried everything:

-Changing Use simple collision as complex collision to Use complex collision as simple collision (No collision at all)
-Reimport the model with a UCX_ (Also didn’t work)
-Convex decomposition (Not complex enough)
-Setting the PlayerPawnTest to BlockAll
-All of the above combined.

Please help.

(English is not my first language and I don’t have a lot of experience with UE4)

Hi INT3NSE_,

It might be a stupid question but where do you set the collision settings ? on the asset itself or when you place it on the map ?

I have placed a Rock_Cliff asset and set its collision to ground and it is working perfectly.

See screenshot below :

Hi,
I’ve set the collision to ground in my map, and in the assets, I enabled the collision.
But the problem is that it doesn’t match the StaticMesh.
See screenshot below:

Go to collision, select remove collision.

Then make sure you have these settings :

collision.PNG

I can’t test it, after I applied those settings, I got stuck in an infinite loading screen (It worked before)

Specs:

Intel core 17-2670QM @2.2GHz
8gb Ram
GTX 560M
HDD hard disc
Windows 10 64 bit

Weird, that shouldn’t happen on modifying collision of an asset.

Roll back the changes then until we find another solution.

The collision does work (I tested it in testmap with 1 single rock), but in my map it doesn’t. (Maybe because I have a lot of the same stones in 1 level?)

Finaly, it works again, thanks.
In the world settings, Sublevels where enabled. It seems like my laptop can’t handle that.

But…
It’s not perfect. And my textures are messed up. Do you know how to fix that?

Looks like the material is too stretched. Try to make a copy of that material and work on the scaling.