Download

HELP: Can't upload mod!

Hello,

This probably a beginners problem, but I can’t upload my mod. When I click upload I get the following message, soon after it dissapears and it the log it says ‘Upload done’.
44ea0172793b80246b33d5a1160f879708e17518.png

Does someone knows the problem?

I actually experienced this problem when trying to update a mod of mine the other day and it was annoying the **** out of me. The problem stemmed from the Description for some strange reason. I deleted everything I had put in it, or rather cut the description, then proceeded to upload it and it continued without a hitch.

I don’t know if this is the only thing that triggers that specific error, or if it’s one of many, and I also don’t know what the problem was with the description that triggered it. My description was quite large(because I was unaware that it overwrites the mod page on the workshop when you upload) and included “=” signs in consecutive order as a means of formatting. So I don’t know if it was the size, or because of the symbols.

After it uploaded, I went to the mod page and edited the description and pasted what I had cut. It’s an annoying bug, that’s for sure.

Hopefully that helps, if you haven’t solved it by now anyway.

-WM

I reduce the description, but now I get this error:
5d66995c766c0cd842d7dca5b2e52a69b2a34d94.png

Any idea why I can’t?

I accepted the terms of service, my credentials are correct, but I never uploaded something before.
Does anyone know what the problem can be?

workshop_build_item "C:\Program Files\Epic Games\ARKDevKit\ModTools\ModConfigs\

i assume this is the full commandline your are using? Because you slashes are in the wrong direction.

This is something that was printed on the screen by the program itself, I didn’t typed anything. But I haven’t got that error anymore, now I have the second, which says acces denied:(

I think I know the problem, I cooked it as a Total Conversion, but I only added a new functionality. I will try cooking it as a game mod. Also does the primalgamedata of your mod need to have the same name as to original primalgamedata or is a other name also good (if I want the original to be replaced with mine)?

No still <Acces Denied>:(

PrimalGameData in the file name should not be touched, just append an identifier to it to know it’s yours, i.e PrimalGameData_BP_WhateverYouWantHere. Also the Level file in your mod needs to reference the new PrimalGameData in it’s override to load that when the mod is loaded.

-WM

Thank you.

I still says: ‘Failed to create workshop item <Acces Denied>’.
I think it has nothing to do with my
mod file, but something with steam. I made a steam account just to upload this mod, so I m not experienced.

Do you or anyone know what might be the problem? What are the requirements for uploading to steam (I accepted the terms of use and my credentials are oke)?

Thank you in advance

So you’ve never had a steam account otherwise? Thus leading me to believe you do not own Ark: Survival Evolved?

I believe owning the game is a requirement for a steam account to be able to upload to the workshop. Don’t quote me, but I attempted the same thing, I created a separate steam account to upload mods as I wanted to keep my modding persona separate from my gaming, but I was unable to do so.

Yes, I dont have ARK. I was workig on my own project when I saw this contest, I have seen several gameplay video’s and I thought that my mod should be in game. So it was mostly for fun and my computer doesn’t have a good enough videocard, I think. I hoped to win the contest so I can buy a better computer (and ofcourse ARK).

But in the contest rules it said no purchase needed, but I will take a look at it.

I’m not entirely sure, so don’t take my word for it, but it seems like the most logical explanation. Part of my reasoning here is the access denied error appears when getting the License information.

I think the contest was targeted at those who play Ark… but there may not have really been a way to translate that efficiently into the rules and information.

-WM

That would be a pity. I really liked modding ARK. I will take a closer look at the rules.

Edit: It is not said in the contest rules, but according to steam you must own the game before you can upload content to that specific workshop. My computer does meet the minimum requirement, but I heard you’re pc must be very good to run it properly, is this true? Are the minimum requirement enough?

Maybe steam guard blocking it as well? If you don’t have ark how are you testing the mod in a live server setting??

Thanks man ! It was the description you were right, for me at least. I’ve been annoyed by that for quite a while! Thanks again man you’re a life saver :smiley:

I know steam guard is active, but is there a way to turn it of? I test my mod in the editor (here it works fine). Its mostly made for singleplayer, so I haven’t thought about testing it on servers.

You can turn steam guard off, but that’s not really going to help you in this scenario, especially since you already found out for yourself why you’re being blocked. I have steam guard and it only asked me once for my code to authorise the DevKit with my account, with which the Steam CMD prompt worked perfectly fine.

If it meets the minimum requirements, yes, it will run it. But it won’t be the best experience, as you’ll most likely be playing on Low, maybe medium (at least a few select settings on medium). On a PC I play ark on at a friends house, his second PC only has a GTX 770 on which Medium is suggested for and it runs pretty well at Medium on that card, granted, you can generally get away with upping Textures and the like if you leave processing effects, shadow settings, and SSAO and all that jazz at the level recommended for your card and it should still work pretty good. On the 770 I had all the settings at medium, with sky detail and ground clutter at about 15% of the slider, textures at Epic and all but two of the effects listed at the bottom off, and I believe I was seeing something in the area of 50±ish FPS.

However, on my two 980 Ti’s, it doesn’t work the greatest in SLI, but I get good enough performance at epic setting levels.

-WM

Problem solved!

I brought ARK and I could upload my mod without any problems.