Download

[Help] Can not publish UE5 game with DLSS plugin

Hello there.

When I try packaging my game for Win64 with the DLSS plugin, it always throws this error:

“ERROR: Missing precompiled manifest for ‘Launch’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in Launch.build.cs to override.”

I have reinstalled the engine (5.0EA) three times already with no change. I have also tried putting the DLSS plugins in both Engine’s plugins folder (according to Nvidia instructions) and Project’s plugin folder but both will have the same error.

Putting both plugins in both folders would cause the ‘DLSS key is already set’ error.

I have no issues compiling and packaging for UE4 with DLSS.

Has anyone else successfully package a UE5 game with DLSS? I don’t know what I did wrong.

Thanks.

Where did you get DLSS for Ue5?

1 Like

there is no DLSS plugin for UE5-EA1 or EA2 at the moment. have you just compiled your own?

Create a new empty C++ class in the UE5 project, then try again.

There is, Nvidia released past friday, DLSS 2.2 and TSR: Comparing Unreal Engine 5 Upscaling to 4k - YouTube

I actually did that, that’s what caused the error.

If I package the game without C++ Class it will build fine, but launching the game’s exe will throw a ‘missing DLSS module’ error, so I added a dummy C++ class and build again but that causes the manifest error.

UE5 DLSS plugin was released last week.

I still cannot get this to work. I will abandon DLSS for now.

Same here. Maybe it’s time to wait for AMD FSR.

I’d abandon DLSS for the time being anyway. I tested it out and it seems to cause issues with Lumen.