Download

Help! Broken tutorial

I’m trying to do one of the in-editor tutorials. Blueprints > Working with Components on Actors 1

It has a number of issues:

Firstly, it tells me here to add an empty actor to the scene.

But as can be seen, the tutorial box is covering up the Empty Actor item in the list. This makes it a bit annoying since i have to add something without seeing what it is. but it’s minor.

The real issues start here

First of all, it tells me to do this. I don’t know if it matters whether i have Actor(instance) or DefaultSceneRoot selected, it doesn’t specify.

Then there’s this, it says i’ve lost the DefaultSceneRoot

But i haven’t! it’s right there in the list, it’s not gone anywhere.

Clearly something’s gone wrong here, but i try to continue anyway.
And i can’t!

The next button won’t let me continue, it just keeps bringing up the same message. I’ve no idea what i’m supposed to do here. I don’t see DefaultSceneRoot in the add components list, and as mentioned it’s not lost anyway.

This happens whether or not i click “Why is this important” to expand the dialog, i’ve tried three times now.

I’m stuck. Is this my fault, or is the tutorial malfunctioning?

Hi

What is the link to the tutorial and what UE4 you using?

Narg

it’s in editor tutorial

@NanakoAC](https://forums.unrealengine.com/member.php?322672-NanakoAC) just rename the Cone to Base so the editor can see it, cheers

Hello everyone, thank you for the replies
My unreal version is 4.10.2-2818068

Sadly, this does not work. I did try it in my first few attempts. i’ve tried it another twice just now, to be sure, the same issue happens. Cannot proceed past where it claims the defaultSceneRoot is lost

Sorry, I need the link, I can not find it

Narg

Your default scene root aka “scene” you can add to a blueprint, when it’s openend.
Open your BP at the left top - Add Component - Scene
Your animated gif blows my mind…
:slight_smile:

Hi, I’m glad someone else is having this same blocking issue.

Edit: It turns out that this is the natural end of Actor Blueprints tutorial part 1. Just start up part 2 and the necessary “root” steps are there.

Unreal Team: Please add 1 more page to the end of this tutorial part 1, reading: “Please start part 2 to continue this tutorial -->” That will save folks like me an hour looking for online answers to this simple, avoidable issue. Thanks!