Download

help.. beginner, broken project

hi, i don’t really know what’s happened. i left my pc opened during night time and in the morning i found that it restarted(1st mystery). i restarted visual studio and i just tried to compile the project without make any changes… it doesn’t… saying that he doesn’t find iostream.h. after google it i’ve added the line “C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\crt\src”… hit f7, error:LNK1181: cannot open input file ‘delayimp.lib’.so i tried to make a new project from the editor and hit f7—>error RC1015: cannot oprn include file ‘windows.h’. so i tried to do some things (set the compiler v120) and i’ve click on update project in visual studio… and i’ve make the thing more ****** up… now the project doesn’t find the include (engine.h etc etc), doesn’t recognize any macro and it continue to not find ‘delayimp.lib’.

what can i do?

EDIT: i forgot to say that i already reinstalled visual studio 2013 (express) whith no luck

Never got such poltergeist here, but you can try Right-Click your project file (windows explorer) and pick the option to generate the VS/Solution files again.

If what Creasso said does not resolve the problem, I’d try making a simple “Hello World” program and see if your problems persists without Unreal Engine being involved.

great… now my project re-recognize again the unreal engine environment… but the windows part is still broken

not working… he does’nt find “iostream.h”

Are you including via #include <iostream> or <iostream.h>? If its the latter then drop the .h as that may be messing up Visual Studio.

Another thing you can try is to check Visual Studio’s include directory to see if iostream exists. The default location I believe is “C:\Program Files\Microsoft Visual Studio xx.x\VC\include”. However, if you installed Visual Studio into a non-standard location then you’ll have to replace the “C:\Program Files\Microsoft Visual Studio xx.x” part with your path.

i’ve chacked it and there is. thanks anyway… something else?

now i’ve made visual studio work whit an hello world (by setting the folder in the environment variable) but no unreal project compile… my unreal project says something like “the precompiled header file ‘xxxxxxx.h.pch’ belong to a previous version of the compliler or th header is c++ and you are using C (or the opposite)” (i’ve made a traduction cause i have visual studio in italian).

if i make a new project it say that i does not find “windows.h”…

i’m desperate… please help me