[HELP] Ark Dev Kit structure changed!

Hello Ark community,

i tried to install Ark Dev Kit so i can play around with it. I already have UE 4.8 installed, but i don’t think that interfere. I have steam(client) installed in C: and Ark/ArkDevKit in D: !
Anyway, i followed the instructions precisely, but i ran into some issues. Basically the structure of the downloadable from GitHub has changed a lot.

The structure now:

           DotNet -> bunch of folders and files
           ThirdParty -> bunch of folders
           Win32 ->a DLL file
           Win64 ->bunch of DLLs and the .exe
           bunch of folders and files

*It clearly states that i need to extract the 2 .exe and all of the DLLs into ARK Dev Kit\Engine\Binaries\Win64*
I don’t really have that structure into my files. I searched around and found this instead ARKDevKit\Projects\ShooterGame\Binaries\Win64 and i copied everything in the binaries folder(DotNet | ThirdParty | Win32 | Win64)
Then i tried to launch the Dev kit through Steam, it asked me to start it from the .bat, so i did. It then opened the workshop website instead of launching. I edited the .bat to point to the correct path and instead of the website now it loads successfully and then nothing happens.

So, what should i do? Plus, what do i do with the plugins folder. Should i place em somewhere?
(I can provide screenshots if you want more infos)

P.S.: If the DEVs from WildCard roam this FORUM, please update your instructions along with the DevKit. It is a pity to have modders confused when they just want to make the community better.

You cant use a newer version of UE4 I believe is what they actually said they use a Customized UE4 Engine. You have to use their engine.

I just went into ARK Dev Kit\Engine and copy and pasted everything in the \Engine folder from the .zip

The Dev Kit opened no problem for me.

What said. It’s a modified source of UE4 with cherry picked features from newer versions. Also there was no need to edit any .bat’s and redirect them. If you are getting sent to the website its because you are not putting the github binaries in the correct place. Recheck and make sure it is definitively in the correct place.

Easy install of the github stuff to the steam install:

  1. drag the “engine” folder from the zip/folder you got from github
  2. release it into the arkdevkit folder you downloaded from steam
  3. allow it to merge with the engine folder already there
  4. replace any files if it asks you to.

it will place everything where it needs to go by itself, rather than worry about human error with moving .dll’s.

I meant that i have downloaded their modified version of UE, but i have the original as well. I pointed out that i don’t think that interfere.

I did that and worked like a charm so far! Thanks :slight_smile: