Download

Help! Animation Montage changes Z Axis of first animation in montage

Hi there, I am new to UE4, using 4.7.1. So I watched the Third Person Tutorial from the Unreal Wiki page, and copied it bit by bit (downloading the animations suggested, and used in the tutorial(punch animation)), my issue is that in the gameplay, the “PunchStart” animation in the montage drops below the floor, whilst the punching 1+2 moves back to normal placement, then the “PunchEnd” animation drops below the floor again before restoring to idle(which puts it back above the floor).

I manually went through all my blueprints and checked to make sure they were identical to the tutorial(They were), and upon trying again in a completely new project, with another mixamo character I created with Fuse, the same problem arose. I figured it was an animation glitch, but after using the exact animations the tutorial told me to download, when the tutorial had no issue, I discarded that idea. Looking at the montage, when I first double click it I see the same issue before it starts looping and restoring z-axis, but after all that, I then select said animation within montage, and the problem isn’t there. Until Test play. Am I missing something? A Z-Axis somewhere? Or perhaps it has something to do with root motion? I’m unsure. Any advice would be most helpful. My apologies if this is a common “Newbie” problem you’ve answered a thousand times.

Thank you in advance.

Upon slowly dissecting the animation montage, I noticed that it is adding in almost a T Pose, which for some reason is dropping it. However, I can’t see the T Pose in the animation montage anywhere. It’s only the animations that I selected to be in there. Any help would be greatly appreciated.

I’m having trouble reproducing the issue here. Here’s a screenshot of the animation I created in an earlier version of the engine following the tutorial. Running the montage does not result in the animation dropping below the floor or adding a “T” pose anywhere. Note I am in 4.7.3 so try updating to that. Also make sure that in each individual animation sequence, you do not have enable root motion checked.

montage.jpg

Thank you for your response, I played around a lot with the root motion settings, checking them all, unchecking them all. It seems that it is using the T Pose as the “Current” pose instead of idle, and upon re-targeting it hadn’t changed the T Pose (Which I have since deleted), The solution I found that seems to remove the T Pose problem is by changing the blend in and out to 0.0, which eliminates the T Pose altogether. So I’m happy with that for now. I will update to 4.7.3 and see if there is any change, or whether my computer just hates me! Thank you again for taking the time to address my issue.

I completely slowed down the blend in to take screenshots of the issue, it could very well be the mixamo import I used causing the problem now that I think about it. This is the beginning, to halfway through blend in, to punching loop

currentpose.jpg
e1d2ff54c67317c7b98e746212fa242d9f1c9f33.jpeg
punching.jpg