Download

help, about lightmap resolution

Hi, pardon me, this question perhaps many times in here. But am stuck, interest and rookie with UE4.
I know the unreal engine a year ago, but I’ve studied now. I use it for interior, and its great ^^
But my problem is light from sun and direct to windows, they not right.
I include/attach my fbx model file and screenshoot about my problem. i’ve seen many tutorial about UV warp, UV error,etc but cant fix my problem :frowning:
I’ve set up the lightmap resolution, etc but the result still the same. What should I do…? :frowning:
Could someone help about this lightning case.

Pardon me and Thx a lot

Increase the lightmap resolution of the object receiving the shadows. If it’s already very high, then you will need to further split up the object so that the same amount of surface area can have multiple lightmaps.

already increase min lightmap resolution until 2000, still same T_T and I am not join the mesh, and that windows is on single group. What should I do?

Minimum lightmap resolution is a setting under the Generate Lightmap UV’s section, you need to look at the section below that for the actual lightmap resolution which is by default set to 64, use powers of 2 so something like 1024 maybe

still not work T_T
all I can do right now is plan b, turn off cast shadow from light source, and using shadow from point light to manipulate shadow from windows :frowning:

You can also change the lightmap override resolution setting in the properties in the object in the map if you can’t find the setting in the static mesh editor

already tried with override too T_T
sorry to bothering you… but still doest work.
and my plan C now is build lightning, and moving slightly light sources. then the shadow will be like normal. if I rebuild again, then the shadow will be broken, and I move a little so that the shadow looks normal

Then you’re doing something wrong that we can’t figure out. When you move a light it goes to preview lighting, it will look different in-game and will warn you that lighting isn’t built. Using dynamic lights as an alternative to figuring out how to use lightmaps is not a good solution

Oh I found my problem, am setting my light source from stationary to movable. This is funny and the shadow looks normal :confused:
Case close… Thx darthviper and unrealengine ^^