Download

Help[5.0EA] Water Plugin does not interact with landscape

Hi, I am trying to use the water plugin in UE5 and it doesn’t seem to be working correctly. I have a landscape setup with edit layers enabled and when adding a new water body it doesn’t seem to interact with the landscape. The editor also shows a message that says “Landscape editor waiting for edit layer resources to be ready.” I left it to think for a few hours but it doesn’t seem to be doing anything. I do have World Partition enabled for the level so that might also be causing issues.

3 Likes

Hello, I am having the exact same issue. I have no idea what is causing this. It could be the new nanite feature, but that’s just a wild guess.

I had enabled a plugin called "Landmass at the same time, I have the feeling it’s causing the problem. I’m going to disable it.

Yup, that fixed it. Hope it works for you. Have a good day!

The water plugin has the landmass plugin marked as a dependency so it reenables landmass when loading the water plugin.

2 Likes

Ok so I have tried it with out World Partition enabled and it still doesn’t work so I think it is safe to assume that its not World Partition causing issues. I saw a few comments saying that the water feature is buggy on bigger landscapes so I tired on a smaller landscape and that didn’t seem to fix the issue either.

I did find this tutorial using UE5 that has the water working at around 50mins https://youtu.be/UVTzVtxxgE0?t=3011 I followed the same steps that he did in a new project and it still wasn’t working so…

1 Like

The same here. It works on certain landscapes, on big one doesn’t work. I see no pattern here. Just a probability. Don’t understand why it doesn’t work or why it does work actually )

Strange thing… ) And I can’t remove any landscape from my level in UE5 EA 2. Why? :slight_smile:

Looking forward to next updates