Download

[Help][4.26] Water (Plugin) with tiled landscape?

I have a map with a tiled landscape, and I just upgraded to 4.26.

I tried to create a “Water Body Lake” but it seems like the lake isn’t interacting with the landscsape.

I tried to add “Water Brush Manager” and/or “Water Landcape Brush”, but it doesn’t matter on which map I put them on, when I run build I get the following error:

WaterLandscapeBrush1 This brush requires a Landscape. Add one to the map or remove the brush actor.
WaterBrushManager_1 This brush requires a Landscape. Add one to the map or remove the brush actor.

I was able to get it working if I enable edit layers when I import the tiles. I was not able to get it working by checking enable edit layers on tiles I imported before without edit layers.

Are you sure there were no other parameters? my map was imoprted with edit layers on, and I can’t get it to work.

I also tried to use it on the Boy and his kite example project, although I’m not sure if the map was imported with edit layers on, or enabled after (or even if I enabled it personally at some ppoint).

Can anyone else check it?

I am having the same problem with a landscape I sculpted within the engine.

Anyone got it to work? It’s a huge blocker.

Not only I can’t, but I’m even not sure how to debug it.

Would be great to have an answer from Epic on at least how to debug it, check the steps that should happen.

As a workround:
Currently I just used the custom water body lake, which doesn’t do any body deformation.
Do note that the underwater post process also doesn’t work, at least not automatically. I might just do it manually though, I didn’t dwelve (pun intended :p) into it too much

Found the solution, when you create the landscape you need to enable the “Enable Edit Layers”, it doesn’t work if you have already created it and enable it after that. It only works if you enable it before creating it.

Relof - Me, and I’m assuming others, can’t do that for pre-created levels. It’s not that simple.

You can always export your height map, and re-create the base. Your level assets including foliage should be moved off to individual levels without the landscape on them and back after if you need to modify the tile.

It’s a lot of work, ture. But definitely not a “cant”…

Also, as far as I know landscape layers do not support world composition.

They do. Layers aren’t runtime so it shouldn’t have any issues, but either way it doesn’t and it works.

It’s not that simple; world composition with terrain has many bugs, most are very hard to replicate.
As I said though, I created mine with edit layers enabled.

Would also love to hear where is it in the code that requires edit layers to be enabled on creation.

Well it still doesn’t work. When I reimport tiled landscape (even limiting to 4 basic tiles) with edit layers enabled it still doesn’t work right.

Anyone has other ideas?

Did anybody find a solution for this problem? I also have the same one, I already tried reimporting the whole landscape, but it still doesn’t work…

At first, when I didn’t check “Enable Edit Layers” when importing tiled landscape, I did not even get landscape deformation when I dragged and dropped the lake; I only got a visible spline. Then, based on the suggestions in this thread, I started over and this time checked “Enable Edit Layers” in the dialog that comes up from Levels > Import Tiled Landscape… Now, when I drag and drop the lake on the landscape, the visible spline also causes land deformation, but there is no light/texture compiling or whatever and the actual water does not display. I can get the water to display on a default landscape that is created when I go into landscape mode, however.

I’m wondering how many UE4 developers have an ongoing project with world composition and want the new water plugin.
I think I don’t wait anymore for a solution, minimal hope for 4.26.2, but really not much knowing that probably UE4 new grid system in their focus.
Well, there are some good lake, river and ocean assets/plugins, some I already have, so seems I have to finish my project with these.
Visually they look good, even some better than the actual state of UE4 water system, the real loss is not having a coherent system, handling all water bodies in one system.

Anyone working in the past year on anything involving world composition has probably already built their own all encompassing solution. And probably sculpts the ground before hand or uses dedicated meshes.

true, but sculpting is not the only one disadvantage but the new system provides “joints” for rivers, lakes. I have some river connections, river/stream flowing into lakes which look pretty good in the new 4.26 water system.
of course, it can be faked/solved somehow, but with more developing time.
atm I’m using ultimate river tool, some lake blueprints and thinking about the free community ocean or marketplace ocean plugin for closing parts of my map with an ocean at borders.

I think because u are using timeofday map, because I am having the same problem but when I open a new third person map and no longer is timeofday map, it works…

Hello everyone. I managed to add water to my map by doing the following:

  1. Remove everything related to the water plug-in from the scene

  2. Enable “Enable Edit Layers” in the landscape settings on the scene
    image

  3. Create two layers in layers, water and land
    image

  4. In the land layer add your landscape

  5. Add water to the stage

  6. Voila

Hope this helps someone