Download

Heightmap lowest point not starting at z=0

so, how do I fix my heightmap problem?

basically what’s happening is that the black in my heightmap is not positioned at 0 on the Z, but at -24250.0

Considering that this is the heightmap:

this is how it’s shown in the game.

Which, despite not being able to set up:

  1. the max height
  2. some smoothing process
    It’s not that bad.
    but the fact that the ground level is not at z=0 is buggering my off by a lot.

I’ve tried changing many other aspects during the import (such as the Z scale) but I keep having the same problem: with z = 100, lowest point is at -24250, with z = -12100

Either you change the heightmap to start at the proper value to hit 0, or you move the landscape up so it starts at 0, which depends on the z scale you use on import.

bascially you need to shift all the values in your 16bit png up by 65535/2

My height map is a RAW (Photoshop) file, 16-bit greyscale.

I tried saving it in PNG and changed nothing about the position of the 0 :t

So, what you mean with the shift?

here I exaggerated the scale to show it better, but the problem is there from already z=5