Download

Having trouble with Behavior Tree Quick Start Guide - Variable not setting?

Hi,

I am new to the Unreal engine and I am attempting to learn more about blueprints and behavior trees by following the guide here:
https://docs.unrealengine.com/latest/INT/Engine/AI/BehaviorTrees/QuickStart/index.html

I’ve gotten through the entire quick start guide twice now, once after starting with a fresh project (base top down project) but I ran into the same issue both times.

Based on executing the game I see two errors in the Behavior Tree.

The first is in the Blackboard in the Lower Selector stating “value: None(fail)”
The second is in the Second Blackboard in the Sequence stating “value: (invalid)(fail)”

Reference to what the guide had me do:
https://docs.unrealengine.com/latest/INT/Engine/AI/BehaviorTrees/QuickStart/14/index.html

I honestly don’t know where this is going wrong. My best guess is that either target to follow or target location is not getting set somehow (not sure how to check this). When I run the game, the behavior tree says it is simulating but shows up with the above described errors.

I’m using UE V4.8.0.

I will post more information if asked, I currently am unsure what would help solve my issue. Thank you for your time

I have solved the issue with the help of my friend Vormulac.

The issue was in the Blueprint function LineTraceByChannel located in the AgroCheck blueprint. For some reason the line trace from the AI to the player controller does not see the player controller.

The work around that I used was using the return value of the line trace as the condition for the branch and switched the executions for the true and false. I also removed the break hit result and object equals check, and instead rerouted the actor to the blackboard value as object function for target to follow. (Previously the true option, but under my revision the fals

Probably there where other pawn out there… so it searched for that one first (instead of your player)

I had a great deal of trouble with this tutorial also. Just now actually. But I’ve solved it at last.

For the problem was not setting Actor Class in “Get All Actors Of Class” node in AgroCheck. And overall setting all nodes’ default variable values using only images was quite a challenge actually. But it’s working now on 4.11.2