Having Trouble When Trying to Render Sequencer Piece with Ray Tracing

I’m trying to render a sequencer piece out with ray tracing feature on.

But I run into a problem that there is a dismatch between the engine calculation FPS and the rendering frame rate.

When ray tracing is on, rendering this 2.5 minute piece will cost about 3 hours. The rendering is pretty slow.
But the engine calculation FPS didn’t slow down with the rendering rate. It just go with normal speed when the piece is slowly rendering.
As a consequence, when the piece is rendered out, the calculation FPS goes crazily fast. And thus my grass(with vertex animation involving time) and my heat haze(a post-process distortion involving time) are off.

See this video for details

To figure out the problem. I went over some sequencer settings and found one seems to be relevant to my situation.

I toggled this option but it is not making any difference in my case.

Does anyone knows anyway I can fix this problem ? Thanks!

Interesting, this looks like a bug. Can you show your setup of the heat distortion or grass? By vertex animation you mean the normal World Position Offset in your material? WPO and a panner on your grass should work with Sequencer. The SpeedTree wind node also works. Maybe you’re using a node somewhere in your material that is not fully supported with Sequencer?

As a workaround you could multiply the time node with a value like 0.1 or 0.01 and feed it into the time slot in the panner to slow it down.

Thank you so much for your quickly response!

Yes, by vertex animation I do mean the WPO. And I’m using a panner for my heat distortion material. Here is the setup.

But I don’t think the main problem is in the materials of heat distortion or the grass. Because I’m also using a bunch of other stuffs. Like the BP_Sky_Sphere, which is part of the engine itself.
And it has some clouds slowly moving on it. In my situation, the clouds are moving abnormally fast :frowning: You can also see these weird clouds in the video above.

Adding a multiplier to the panners could solve the problem with the grass and heat distortion. But it won’t fix the problem with other stuffs like physical simulation(I have hair simulation and cloth simulation). So I might need to fix this problem at the root.

Ok, this should definitely not be happening. What version are you using? I used WPO and Cloth Simulation with Sequencer in 4.23 and it worked fine. Have you tried to migrate a single grass mesh to a new scene and test it there? You could increase the rendering time by upping the ray samples a lot.

Your Time Scale of the shots is on the default? RMB on Shot>Properties>Time Scale 1

Problem solved! I migrated the map into a new proj and it renders well. By contrasting these two settings, I found there is a parameter called ‘delay every frame’ under animation section. I didn’t set it to zero and that’s why I was getting wrong rendering result.

This is a stupid flaw. Sorry for disturbing you and thank you again…

No problem, glad it works now!