Download

Having trouble compiling 4.11

I haven’t had this issue with previous versions, but 4.11 does not want to cooperate. Compiling with Visual Studio Community 2015, and all three times I’ve tried it hangs parsing UE4Editor. This time it’s been stuck here for several hours:

[1499/1679] Link UE4Editor-Kismet.dll

I’ve followed the instructions on Epic’s site now and in the past, running Setup then GenerateProjectFiles with no problems. I’ve also tried compiling with Blend For Visual Studio just in case but the same thing happens there. The solution is incompatible with VS 2012 so I wasn’t able to try that.

Has anyone else had this problem?

I know it doesn’t necessarily help but I haven’t had the issue here… The only difference is I’m using Visual Studio 2015 Enterprise. When I do a clean pull from master, run setup.bat, & generateprojectfiles it compiles fine here. I haven’t seen an issue where it just hangs on one portion.

It seems like stopping the build and restarting it, then repeating that once it hangs again until it gets through the build works. That’s… mildly annoying though.