Having issues with my blueprints crashing upon opening 4.13

Everytime I open any type of blueprint it crashes, just started 3 days ago and I tried looking in references to see if it was something there. not too sure what to look for thou still learning a lot on here, but I even tried seeing if going to the next version my just kick it to work again. still nothin I tried seeing if I created a new blueprint but still nothing,
Thanks.

Hi kage16,

When I look up the primary crash from the last 3 days, in the Source Context of the crash report it says:

  379       		// Generate new one
  380       		CreateNewGuid();
  381       	}
  382       	// Moving to the new style comments requires conversion to preserve previous state
  383       	if(GetLinkerUE4Version() < VER_UE4_GRAPH_INTERACTIVE_COMMENTBUBBLES)
  384       	{
  385       		bCommentBubbleVisible = !NodeComment.IsEmpty();
  386       	}
  387       
  388       	if (DeprecatedPins.Num())
  389       	{
  390       		for (UEdGraphPin_Deprecated* LegacyPin : DeprecatedPins)
  391       		{
  392 ***** 			LegacyPin->Rename(nullptr, GetTransientPackage(), REN_ForceNoResetLoaders);
  393       			LegacyPin->SetFlags(RF_Transient);
  394       			LegacyPin->MarkPendingKill();
  395       		}
  396       
  397       		DeprecatedPins.Empty();
  398       	}
  399       }
  400       
  401       void UEdGraphNode::PostEditChangeProperty(FPropertyChangedEvent& PropertyChangedEvent)
  402       {
  403       	Super::PostEditChangeProperty(PropertyChangedEvent);
  404       
  405       	if(const UEdGraphSchema* Schema = GetSchema())
  406       	{
  407       		Schema->ForceVisualizationCacheClear();

This usually indicates that you have upgraded your project (is this the case?) and that the old pins in the Blueprints from the previous engine version are not compatible with the version you have upgraded to. If this is the case, the best approach is to go back and work from your older project, if you have not already overwritten it.

Steve H.

I did upgrade it to .14 trying to fix it but ive been using the .13 version for months and this just accured. otherwise most of the things I’m using is for the .13 version, any chance its from something else

I was trying to import a model that wasn’t transferring correctly for a few days from blender, could it be from that

You could try removing the model temporarily to test. Just to be clear about versions, though, did you upgrade to 4.14 and then revert to 4.13 or did you have a separate 4.13 version that went back to?

In either case, I cannot tell exactly what is causing the crash from this log alone. I suggest running a map check on each level and checking/fixing any resulting errors. Also try selecting the Contents folder in the Content Browser and selecting “Fix up redirectors in folder.”

If this does not work, make a back up of your Project Folder, then delete the Intermediate and Saved folders from the Project Folder that’s still active. You can also try deleting the Derived Data Cache folder from the UE4.13 install directory.