Having issues with inventory

So I followed Wes Bunn’s inventory tutorial and established a basic inventory system. At first everything worked fine however; I ran into some issues when trying to customize it.

Here you can see in game I have a healing potion, that I can pick up, and drink from my inventory, and works perfectly. It correctly restores my health, and the actor gets destroyed when I drink it, or hidden when I add it to my inventory.

Now the problem comes in when I attempt to add physics to my items. As you can see, when I add physics, the potion gets bumped correctly, but the default scene root remains static, keeping the pickup text at the default location, as well as allowing me to pick up the item from here.

After looking online for a solution, I found That I can replace the default scene root with the mesh component.

At first this seemed to fix the issue. (It wont let me add anymore attachments, but you can imagine how it looks.) When my character bumps the potion, it moves using the physics, and the pickup text correctly follows. I also pick up the item correctly.

But then this creates a new issue that I cannot identify. Using the potion no longer works. It destroys the actor still as it is supposed to, and displays all action text correctly, suggesting the references in my other blueprints still work however; when I drink the potion it will no longer refill/decrease my health. The blueprints are identical, the only difference is that I replaced the actor’s root component with it’s mesh.