Download

Having issues with floors not getting same baked lighting as walls/ceilings

That is actually the exact issue. If issue was somewhere else, I’d have problems with Sky Light inactive.

From skimming ArchViz section I see people use 4.11.2 and not 4.12.5 or 4.13. Plus in ArchViz scenes floors are enclosed inside the walls and not placed as in my scene. If I model my “crypt” in 3D app and not assemble it in UE4, I will have no issues with lighting.

Filed bug report Sky Light issues with mixed environments - UE4 AnswerHub

Thanks

What you have is more related to content creation issues that have been pointed out here in this thread.

4.12 on the left, 4.13 on the right
e6dcef9310665ca192e3e9532ddb5a01ce1ca6ac.jpeg

This is the template floor from the default level using a basic white material and a 256 lightmap resolution and there is a little bit of bleed due the floor having part of it’s faces outside in the light. I only used higher lightmap resolution to limit light bleed with this copied floor mesh.

This scene is lit entirely by the skylight with no directional light. This looks correct to me.

These are the settings used in the skylight.

skylightsettings.png

You wil want to troubleshoot your level and make sure that you are developing your content correctly. Using some or all of the suggestions made previously in this thread would be a good start.

[MENTION=4894]Tim Hobson[/MENTION]

Thanks, I’ll try it 4.13 again (got all mixed up between versions already :o ).

I strongly disagree about content issues in this particular case. I am using Infinity Blade assets and kitbashing technique for level design. That should work out of the box, but it doesn’t (which also looks like it doesn’t work for you in 4.12 either judging by the screenshot on the left). Several folks on Unreal Slackers confirmed that they had the same issue and the only fix was to model rooms with floors perfectly fitting inside the walls.

One of the UE3/UDK strong points was ability to build levels using kitbashing, which isn’t always correct solution, but fastest and fast is essential for indies. If UE4 isn’t designed to allow such freedom, it should be noted somewhere clearly (preferably in the Skylight section of the docs, since like I stated before I have no issues when not using Skylight).

[MENTION=4894]Tim Hobson[/MENTION]:

Test case based on FPS Template: FPS_Template_4125.zip - Google Drive

Same issue I’ve been having.

Btw, I tried baking my project in 4.13 and still have the same issue.

I just made a quick test on your test template on the UE4 4.12.5, and got this:

A view from the inside, the bright floor problem is clearly visible:
64dcd665206b58b327c8b3b145280cdd374ba831.jpeg

After i made a production building with no change or adjustments:

I can’t get looking into it further at the moment as i’m a bit strained to my time limits, sorry(!), but the unwrapped lightmap channel UVs doesn’t seem to be looking good (pixel/space between the uv’d sides):
91e7e360b66726ed084c691b8babb31fad81adb4.jpeg

@Ashh111

There is nothing wrong with UV map layout. It looks good to me. Plus Epic’s subsidiary did the art (Infinity Blade guys), so it’s safe to say they know what they are doing with art for UE4 engine.

By “production building” do you mean Production quality for lighting or did you actually deployed production build for a platform ?

If all you did was to build with Production quality, then for whatever reason that doesn’t work for me in my other project (I haven’t tried building this test case with Production quality). Lightmass settings are identical with FPS template, lighting setup is identical too (same lights, same settings).

Medium build quality is enough to get acceptable result. However there is a minor light bleed near the walls.

Edited my post above.

How do you get a rid of light bleed completely ?

Well, the easiest (but not effective way) is to increase resolution for floor segments to something like 1024. Also you can try to tweak uv’s to optimize useful space. Also, try to avoid huge floor pieces with closed rooms on it (if lighting inside room is important)

Now I am thinking to add brush that fits perfectly inside the room and raise it a tad above the existing floor. This way it will be as dark as walls.

These are existing pieces of geometry, so I can’t really do much about it for this project. Could probably make brushes to fit around the room and inside the room, and get a rid of the floor pieces, but then it won’t be efficient, production time wise.

This would be a good place to start.

Changing the setting to Production vs Preview build for lighting quality invalidates this example. 4.13 gets even better results with less light bleed around the bottom edges. Mostly because the floor is uneven and the walls are not touching in those parts.

Comparison here from left to right: Preview, Medium, High, and Production and all done in 4.12 by only changing this value.

If you go a step further and set the walls so that there is no gaps between the floor and use a floor piece that does not have significant portions outside in different lighting conditions you can get better results. This is a just a single floor piece slightly scaled to the width of the room with minimal overhang into the outside lighting and it is using the default lightmap resolution of 64.

2739d3a395ca074490771b35d21962de9c2996ca.png

These suggestions have been previously mentioned in this thread.

Edit: Looks like some of the other community members beat me to it while I was putting my post together. :slight_smile:

Aye folks, thanks for being patient with me :o

I’ll do more baking and playing with Sky Light intensity / distance.

Alright, did the Production build in 4.13 and got proper shadowing \o/

But, I had to mess with distance threshold values and that screwed my lighting on the level :confused: (I used large values and now my map looks like it doesn’t have Sky Light)

So now I am trying to find right settings so that the level looks good and shadowing indoors is correct.

Finally, got it working properly using 4.13. I didn’t check 4.12.5 again, but tweaking Skylight parameters and baking in Production quality did it for me \o/ (although I don’t think I will be baking in that quality until I really need to check the overall final look - takes forever to bake)

Thanks a bunch folks !!!

The only issue I still have if the piece of sand dunes that protrudes inside the “crypt” - never gets dark :confused:

Also while I was experimenting with it, I got another question here: SkyLight - Capture Scene vs Cubemap - why so ... different ? - Rendering - Unreal Engine Forums

Thanks

Last part of my post above explains why that is.

Oh, finally got everything look good! Thanks

Btw, wouldn’t it be nice to put all this into docs (all in one place, like “Types of environments” -> “Lighting mixed environments”), so that no other person have to go through this painful trial and error? :slight_smile:

I think the information for lightmass is pretty well documented without bloating it with a bunch of do’s and don’t’s. That’s what my wiki lighting guide is for after all. I’ll consider putting an example of this up there. You should read through it though. There is a lot of good information there that are common issues for those not familiar with lighting in UE4. :slight_smile:

Did a bit more baking today.

Oddly enough, when using SLS Cubemap, it get results I need (like on [MENTION=4894]Tim Hobson[/MENTION] 's screenies).

However when using SLS Capture Scene, results aren’t that great, and sand is too bright for indoors.

What’s the difference (besides the obvious) between the two and when one should be user over another ?

Thanks

Never mind, I figured out SLS Capture. All good now.